Sign in with
Sign up | Sign in
Your question
Solved

Windows 7 "Ntldr is missing". I only find Win XP repairs. IS THERE A REPAIR FOR WINDOWS 7 with the same problem??

Last response: in Windows 7
Share
October 20, 2013 1:17:37 PM

Here is basically what happened:

---LT was working fine until my C: turned red when I opened "computer".
---I had just completed downloading itunes tv shows and thought itunes was on my external HD, but it was on C: , which made it turn red since it was almost to capacity
---I attempted to move itunes to the EHD by backing up all the iTunes data to the EHD; then uninstalling itunes from C: and then re-installing iTunes on the EHD (just like my Amazon movie player is installed; never have had problrms with it) and there was plenty of space for the switch
---LT asked to restart and when it booted, there was a bootfile message error that past by quickly so I never got the exact terminology of that error.
---I was told to goto F8 to repair the problem.
---When I did this and then rebooted the LT (as requested by the LT) I encountered:
"NTLDR is missing" press CTL+ALT+DEL to restart
---When I did this, the LT just became stuck on a loop of reboots with this message
---This happened about a week ago and I hadn't tried anything else until today when I was able to obtain a working computer (windows XP)
---I followed all the directions from the following site: http://tinyempire.com/notes/ntldrismissing.htm
and nothing worked after attempting every direction and error solutions.
---However, all the references are for Windows XP

Is there something different I need to do to repair this problem since my broken computer laptop (LT) is Windows 7?

Please Help??

Best solution

a b $ Windows 7
a b D Laptop
October 20, 2013 2:53:13 PM

Can try booting into SAFE MODE, if good run a Virus and a Malware SCAN, could do a system restore, or try running System File CHeck from the command prompt as Adminitrator SFC /SCANNOW .... if you have a system disk for your OS or can borrow one, can boot from it and have it do a system repair instead of new install
Share
October 20, 2013 3:27:43 PM

ok, great thanks. I have done some of that:

---I have the OS disk, but it wont boot. It continues to go to NTLDR screen when powered on, and stays stuck in a boot loop. So that disk doesn't work for repair that I tried already. (BIOS is in proper order)

---I can press esc during boot (before blackscreen of NTLDR error msg) but only have a few start up options

---Of these startup options, I have checked BIOS (its in correct order); system diagnostics find no problems at all; F8 will not work, so I cant get into safe mode or access any of the F8 options.

---The only thing I can do is: (boot, esc , F9, internal CD) after putting in the "Media Direct 3 re-installation" disk. It asks 3 questions:

1. Allocate all available space to the C:\ partition

2. Specify the size of the C:\partition ; then all remaining space will be allocated to a D:\ partition

Q. Quit

*****Note: Options 1 and 2 will allocate Utility and Media Direct 3 partitions.

Make a selection: _


---If I select options 1 or 2 a message appears:

"this process will completely destroy all data on your hard disk drive"

So, I press Q to quit,

But when I press Q (quit) to get out of that screen and eject the disk; it pops up a black screen that looks like command prompt , but like this:


A:\>_


when I put in C: at the blinking cursor, then I get


C:\>


however, it doesn't look like the regular command prompt window (like from the advanced recovered options window when the computer is working fine) and it doesn't respond to most the command prompt solutions I find online to help with the problem.

--- (ie: i was searching for a command line that would back up all my files to a hard drive (external) and then just go buy another computer. I figured this was my last option since I don't know what else to do).

note: when I have used command prompt in the past it starts out as, C: , not the prompt I am getting C:\>



Any other suggestions???


thanks for your time
m
0
l
October 20, 2013 5:07:40 PM

Zepln, I got your message. NTLDR is the Windows NT bootloader. There can be any number of reasons it was missing, ranging from the hard drive being physically faulty, the filesystem on the hard drive being corrupted, the bootloader file itself being corrupted, or you are the victim of a boot sector virus.

I think the boot error message probably had a lot of information in it that would have been helpful. I would probably start first by checking if the internal hard drive itself is good by running a bootable Linux CD (which does not require the hard drive) and then running smartctl to see if the HDD throws errors or not. If it appears fine, try to mount it. If it does not mount, the filesystem is probably toast. You can try to repair it with fsck but I don't know if that would work well. You'd have to reinstall at that point. If the FS mounts, I'd dump all of the files you want to save onto the external HDD and then reinstall Windows from scratch. I will admit I am not really a Windows guru as I have been using Linux for over 10 years and haven't spent much butt time in front of Windows machines in a long, long time. The last version of Windows I really spent a lot of time with was Windows 2000 if that is any indication.
m
0
l
Related resources
!