Sign in with
Sign up | Sign in
Your question

No signal monitor, Keyboard and mouse after installing new GPU and adding 8GB RAM

Last response: in Graphics & Displays
Share
October 22, 2013 11:07:36 AM

Hello Everyone,

I was really excited by receiving my new Nvidia Geforce gtx 760 MSI GPU and 2x 4 GB Crucial Ballistix RAM.

I unplugged my old GPU and added my 2 RAM sticks, then the monitor gave no signal and later on I discovered the keyboard and mouse didn't either.

I plugged my old GPu back in but those things wouldn't work again, I also removed my new RAM and placed my old RAM back in the same slot.

HDMI, VGA and DVI don't give signals aswell... I've also tryed new VGa cable and a new monitor but nothing changed. There must be something wrong in the motherboard even though I've also placed both GPU's in the other GPU slot aswell...

We also connected the VGA to the motherboard but nothign happened aswell... I think something in the motherboard is broken or something but Before I changed the GPu and RAM it worked perfectely fine...

Can anybody please help me with my problem, I'm a real noob :S...

Trust me I've tryed every combination of Gpu Ram and cables USB ports name it...

Maybe there is something wrong with the CMOS battery. And It might also be good to know that I've unplugged several things while the PC was on power ( which probally ain't that smart :D )...

I would really really appreciate any help!!!! :) 
My motherboard: http://tweakers.net/pricewatch/275126/asus-p8h67-m-pro/...
a b C Monitor
October 22, 2013 12:21:28 PM

Start the PC without any RAM sticks, and listen for beeping sound from MB, if it beeps then its ok, if not then its dead. And don't ever unplug or plug anything(except USB drives or hot swap SSD) when the PC is on power.
m
0
l
October 22, 2013 12:46:27 PM

lonewolf7 said:
Start the PC without any RAM sticks, and listen for beeping sound from MB, if it beeps then its ok, if not then its dead. And don't ever unplug or plug anything(except USB drives or hot swap SSD) when the PC is on power.


Thanks, for the comment, if it beeps what do you recommend then? And what are the consequences if I unplug/plug in devices in the motherboarf while the power is on? Is it just dangerous or also damaging to my pc?
m
0
l
Related resources
a b C Monitor
October 23, 2013 9:40:51 AM

It would damage the components. First see if the MB beeps or not, then think of anything else.
m
0
l
October 24, 2013 4:03:28 PM

Thx all its solved Ram apparently wasnt pushed in good enough...
m
0
l
a b C Monitor
October 25, 2013 10:59:10 AM

So far so good. Glad to hear that.
m
0
l
!