New built pc wont boot/no display

all new components
all lights and fan are working when turned on
Monitor is working

my set up
Motherboard : GIgabyte aa8x sniper
CPU : AMD A8 6600k stock heat sink
Ram : Crucial Ballstix Sport d3 4g 1600mhz 1 stick
PSU : Corsair vs450
4 answers Last reply
More about built wont boot display
  1. Check that the Ram is properly inserted( it should clip in properly). This was my problem recently.

    EDIT: Also are you using the correct type of cable for your monitor? Eg. Mine uses a VGA cable
  2. when it start can you hear the BEEB ?

    are you useing any GPU ? if you do so than

    if you do than just change the Adapter for the screen in the back to the motherboard and restart it. it could be the GPU driver not installed yet.
  3. its the ram. but when i tested it(4gd3 1600mhz) on a older ddr3 board its working fine.then
    used my old 2g d3 1333 ram on my new gigabyte a88x then its now showing display

    the question is why does the 4gd3 1600mhz ram wont work on the new gigabyte a88x board?
    while its working fine on a older board
  4. kr0n31 said:
    its the ram. but when i tested it(4gd3 1600mhz) on a older ddr3 board its working fine.then
    used my old 2g d3 1333 ram on my new gigabyte a88x then its now showing display

    the question is why does the 4gd3 1600mhz ram wont work on the new gigabyte a88x board?
    while its working fine on a older board


    2 answers for this

    Bad stick slot

    Or

    Not supported as an wrong RAM they don't match to gather
Ask a new question

Read More

New Build Boot Hardware Problem Components Displays