Sign-in / Sign-up
Your question

AMD Catalyst Drivers

Tags:
  • Drivers
  • AMD
  • Catalyst
Last response: in Open Source Software
October 22, 2013 1:17:28 PM

Hi, I am new to linux, and so installed mint 15. First off, i had to use my intel integrated gpu because my AMD Radeon HD 6670 would have big green dotted lines down the screen and mint would not boot up properly. So i downloaded the 13.4 drivers from amd, but the file would not install anything. I installed the fglrx-amdcccle drivers from the software manager, but they install catalyst 12.9. I want to update to 13.4 but the file from amd will not work, any ideas?
Many thanks

More about : amd catalyst drivers

October 22, 2013 1:18:50 PM

Also, with the current drivers, all is working okay, apart from when changing workspaces, the background does not show, only the open applications. And there is an "unsupported hardware" watermark in the bottom right corner.
Cheers
m
0
l
a b \ Driver
October 22, 2013 2:11:00 PM

Instructions here:
https://help.ubuntu.com/community/BinaryDriverHowto/ATI...

linux mint15 = ubuntu 13.04

btw the default "radeon" driver should be fully supported in mint15, don't know why your install is having issue though, would need to look at error logs to provide insight:
/var/log/dmesg
/var/log/Xorg.0.log
m
0
l
Related resources
a b À AMD
October 23, 2013 11:04:22 AM

Hi, I have a Radeon HD 7870XT, and I have not experienced this issue before; however, I have an idea.

How did your video card work before you installed the proprietary drivers?

I ask because Linux Mint 15, being based on Ubuntu, should have the open source drivers for your HD 6670 as the default. You should be able to pull up your display settings (not super familiar with mint, but I run Ubuntu 13.04 at home), and change the drivers from the proprietary drivers to the default open source drivers. Check and see if that fixes your issue. You may not need the proprietary drivers for what you're doing unless you're doing heavy gaming.

Are you using your PC for gaming primarily, or productivity type stuff?
m
0
l
October 26, 2013 5:16:57 AM

When I tried to use Mint without the proprietary drivers, the mint sign would fade in from the black background, but there were thick green lines, looked almost as if they were made of artifacts, and then my screen would turn on and off, and mint would never actually boot, so i had to use my on board intel graphics and manually install the drivers before i could use my card. I had to use a tutorial on ubuntu to do this, but it finally installed 12.9. I have only just installed it for the first time so i dont use it for much now, plus with all my stuff being on my windows hard drive I have to find a use for it. Mainly it will be a general use OS because it is much faster, cleaner and better looking than windows, but as the game industry for linux grows I will be gaming. I never had the driver problem with windows, but to be honest, i think the card is worn out, it was a year old when i bought it from a friend, its from vtx so its a cheap card anyway, plus i have given it a hard life with overclocking.
m
0
l
October 26, 2013 6:06:59 PM

I have it all working fine now, i had problems with sudo so had to do a fresh install and followed the link above, i dont think it is 13.4 but its as good as it will get, thank you for all your help :) 
m
0
l