Sign in with
Sign up | Sign in
Your question
Solved

4670k on z87-a won't wake from sleep

Last response: in CPUs
Share
October 24, 2013 9:41:09 AM

Hey guys, I put together a new build and everything works great except for one issue. I have an i5-4670k cpu in an asus z87-a motherboard, occasionally when the computer goes to sleep the red cpu error light on the motherboard lights up and the computer refuses to wake. It doesn't come back on after turning it off and on one time, it takes two or three times before the error light goes away and the computer boots again. Not even sure where to start with this one. Any help would be greatly appreciated.

Build:
Cpu: Intel I5-4670k (not overclocked)
Mobo: Asus z87-a
Memory: 2 - 4gb Gskill Sniper 1600
Psu: Corsair 750tx
Gpu: Sapphire Amd 7970 oc w/ boost

More about : 4670k z87 wake sleep

October 24, 2013 9:54:39 AM

is your psu Haswell compatible? If not, then there's your problem
m
0
l
October 24, 2013 11:52:27 AM

Yes I made sure all the parts are compatible via QVL documents.
m
0
l
Related resources
October 28, 2013 1:48:09 PM

How old is your PSU? Have you added any other components recently? Did you get any error messages (both in OS or during boot-up)? About the PSY, perhaps the capacitors in are malfunctioning or gone bad (this is one of the most common problems with PSUs, they get "old"). If you can, switch the PSU with another similar unit and see how it goes
m
0
l
October 28, 2013 6:14:56 PM

No, everything is new, all came on the same day. It's all listed in the original post. Everything works wonderfully, except for when the computer goes to sleep. Usually after it has been asleep for extended periods of time, it won't wake with mouse, keyboard, or power button. The only way to get it to come back on is to do a hard shut down and then turn it back on. I've had sleep turned off for the past week and have had no issues, but I would like to be able to use sleep mode eventually.
m
0
l
October 29, 2013 1:46:36 PM

Have you tried updating the mobo bios? I wasn't able to wake my 4770k from sleep until I did that
m
0
l

Best solution

a b à CPUs
October 29, 2013 3:08:17 PM

The OP's PSU is the Corsair 750TX as stated above. Corsair's website lists it as Haswell compatible.
http://www.corsair.com/us/blog/haswell-compatibility-wi...

My Gigabyte Z87 has BIOS options that control Sleep states, Wake on LAN, etc. Have you checked all those settings?

You might also update your BIOS in case there is a need to do that.

Personally I don't use sleep states. I just power my system down when I'm not using it. My wife lets her PC sleep and it drives me nuts. Every time the kids bump into her desk the mouse moves and the computer turns on for 20 minutes.

Latest BIOS for your motherboard was released YESTERDAY: BIOS #1504
http://www.asus.com/Motherboards/Z87A/#support

Their change notes don't say anything about sleep states.
Share
October 30, 2013 7:58:25 PM

Yes. I did update the bios right after getting everything hooked up. I'm still using 1405, I'll update tomorrow, as well as have a deeper look at the Sleep states. Thanks for the ideas I'll let you guys know if this changes anything!
m
0
l
October 31, 2013 10:21:00 AM

Also, check you device manager and make sure there's no warnings/errors for your usb drivers. It might not be a problem with sleep, just waking up because of a problem with the usb driver. Good luck!
m
0
l
October 31, 2013 11:44:48 AM

Ok guys. I've updated the bios to 1504, made sure there are no usb issues, and looked around the bios at the cpu power options. I didn't change anything except for turning off power savings to usb devices. I manually put the system into sleep and still get the red cpu error light on the mobo as soon as the computer goes to sleep. So again I had to do a hard shut down, when it boots back up it tries to "resume windows", followed by nothing but a black screen, hard shut down again, power back up, and I get power but nothing displayed on screen, hard shut down again, power back up, it then asks if I want to continue with resume or delete the resume data and continue to boot, I continue to boot and it works fine. Very annoying issue. I'll try disabling the c7 sleep state and see if that does anything.
m
0
l
!