Sign in with
Sign up | Sign in
Your question
Solved

i5 3570k wont exceed 1600 Core Speed

Last response: in CPUs
Share
October 24, 2013 3:06:24 PM

Hello guys!

So I recently purchased a new motherboard, ram and processor to upgrade my gaming pc from a q6600 that was beginning to show its age. Unfortunately, I noticed little in the way of improvements and was beginning to debate OCing the new hardware when I noticed in CPU-Z and Core Temp that something was amiss.

First I am currently using Windows 7. My hardware is:
Intel i5 3570k
http://www.newegg.com/Product/Product.aspx?Item=19-116-...
Asus P8Z77-VLK Motherboard
http://www.newegg.com/Product/Product.aspx?Item=N82E168...
CORSAIR Vengeance 8GB
http://www.newegg.com/Product/Product.aspx?Item=N82E168...
Gigabyte 460 GTX
http://www.newegg.com/Product/Product.aspx?Item=N82E168...

Going into CPU-Z I first noticed my RAM was running at a lower 667 mhz, rather then 800 as it should have been. I went into the bios and correctly set the profile for XMP but that still did not solve it. Manually setting the Memory frequency to DDR 1600 however did fix that problem.

Next I noticed that my core speed on the 3570k was only 1600 (bus being 100, multiplier 16). I did research and noticed that this is standard for when it is at idle and speedstep is enabled. However, even under stress it was not moving (I used prime95). I went into the bios and disabled speedstep, the various "c" options and made sure the power plan in windows was set to performance (min 100%, max 100%). Still no dice. I even went as far as to change the CPU multiplier in the bios to manually be 32, 34 but it always was showing 16 in both CPU-Z and Core temp.

So I am baffled and hoping that I missing something obvious or something completely over my head. Any help would be appreciated. Thanks!


EDIT: Picture of core temp and cpu-z running with prime 95: http://imgur.com/El1SiL8
a c 1510 V Motherboard
a c 540 à CPUs
October 24, 2013 3:46:30 PM

Sounds like the BIOS needs to be updated
m
0
l
October 24, 2013 3:52:44 PM

Tradesman1 said:
Sounds like the BIOS needs to be updated


My bios is version 1104 which matches the latest version according to asus' website.

m
0
l
Related resources
a c 1099 V Motherboard
a c 853 à CPUs
October 24, 2013 3:56:52 PM

Either a faulty board or CPU, so most likely board. I pretty much have the same setup (had it for a while now running the original BIOS) and I did not even have to activate XMP to default to 1600Mhz ram.
By the way you did not list your PSU on the odd chance this is a power issue.
m
0
l
a c 1510 V Motherboard
a c 540 à CPUs
October 24, 2013 3:58:23 PM

Is anything running in the background, open a few browser windows and start a virus scan, then open up CPU-Z (and might get the new version if you don't already have it, 1.67 was recently released
m
0
l

Best solution

a b à CPUs
October 24, 2013 4:15:02 PM

Give ThrottleStop a try. Try disabling BD PROCHOT. If this gets your CPU working properly then you have a bad sensor on your motherboard that is telling your CPU to throttle.

ThrottleStop 6.00
http://www.thedigitalhq.com/downloads/

You can also try adjusting Set Multiplier to the highest value and then click on the Turn On button. Post some screen shots if you are still having problems.

I would also suggest setting your BCLK back to 100.0 MHz in the bios. It is safer to increase the multiplier if you want your CPU to run faster.
Share
October 24, 2013 6:13:08 PM

Sorry about not including the PSU I knew I was missing something!

I have an Antec Earthwatt 750:
http://www.newegg.com/Product/Product.aspx?Item=N82E168...

I just flashed bios to ensure it was indeed the latest one and the same problem.

Me and buddy went through just about every option in the bios and still were having no luck. We have not been able to get the multiplier to move from 16x. We did move the bus speed up once and it worked and got us to 1680.

I also downloaded ThrottleStop and it worked! It seems that BD PROCHOT is the culprit. I pushed it up to 34x while the bus speed was still at 105 and it worked but crashed. I don't know what caused the crash but I reset all bios settings to how they were and ran it again, this time setting the multiplier to 30x and it is working.

Thanks for that recommendation. It looks like I need to talk to ASUS about getting my MB replaced.
m
0
l
a c 1510 V Motherboard
a c 540 à CPUs
October 24, 2013 6:20:33 PM

Glad to hear all is well, have some fun !
m
0
l
a c 1099 V Motherboard
a c 853 à CPUs
October 24, 2013 6:34:31 PM

Yep faulty board!
m
0
l
!