Sign in with
Sign up | Sign in
Your question
Solved

USB 3.0 External HDD stops working after a few minutes.

Last response: in Storage
Share
October 24, 2013 6:47:07 PM

I am not sure what is happening but it was working prior to a few days ago.

I have an external Western Digital passport hard drive plugged into my computers front USB 3.0 port. It works for a while and I can access all files and write to it but after a few minutes it disappears from My Computer. The light of the HDD is still on though and I can hear it spinning.

It doesn't matter which front USB port I plug it into, eventually it will disappear.

Also when I plug it into a front USB 2.0 port it says USB device not recognized or has malfunctioned. Perhaps I no longer have the proper USB drivers? My USB headphones work and my ipod charges in the 2.0 ports. Do I need to do something with my chipset drivers? I am not sure which drivers control the USB ports.

Does anyone know whats wrong? Device Manager says everything is OK. Maybe I need to do something with my USB ports?

I recently had an internal HDD fail but I managed to ghost it to a backup HDD, so maybe that caused it?

Here are my specs if it helps:

Windows 7 64 bit. Service Pack 1.

Motherboard: MSI Z77A G45.

Thanks a lot!
a c 297 G Storage
October 25, 2013 1:00:53 PM

Try it on back USB ports of MB.
m
0
l
October 25, 2013 2:38:25 PM

lonewolf7 said:
Try it on back USB ports of MB.


It works in the back ports it seems, but not the front. Anyone know whats up with the front ports? Is there a way to reset them maybe?
m
0
l
Related resources
a c 297 G Storage
October 26, 2013 12:06:42 PM

No there is no way to reset them. Any other device will work fine on front USB port, but ex HDD and PD. They (HDD,PD)will work for some day or for months and then will malfunction out of nowhere, so nothing can be done, except formatting and clean installing the OS. This is how it works.
m
0
l

Best solution

October 27, 2013 11:24:33 AM

I managed to fix the problem. What I did was uninstall the front USB Hub and reinstalled it and not it works as good as new.
Share
a c 297 G Storage
October 27, 2013 11:41:41 AM

Glad to hear that. Cheers.
m
0
l
!