Sign in with
Sign up | Sign in
Your question
Solved

Installed Windows on Acer Aspire 5553G-5357 and can't figure out display driver issue

Last response: in Windows 7
Share
October 26, 2013 11:30:39 PM

Earlier this evening I installed Windows 7 Ultimate 64 Bit on on Acer Aspire 5553G-5357. I did this because the included installation was only Home Premium and had too much bloatware for my tastes. Not only that, but for seem reason there was no Catalyst Control Center/AMD Viston Engine control. The problem is I'm now starting to regret it. I downloaded all the drivers I thought I'd need, and everything seemed to be going well, until I got to the display driver. It turns out this computer doesn't only have the Radeon HD 5470 graphics chip, but also an integrated Radeon HD4xxx (I think 4250). I've installed an odd assortment of graphics drivers.

At first I attempted just installing the latest drivers for the 5470. No go, still stuck in 1024x768 with no hardware acceleration. The Vision control engine only has options for setting lower clock speeds on the CPU. That's nice, but not what I need. This display is 1366x768 native, and I really need that.

So I uninstalled those drivers and tried a method I found on another forum where you install the latest Catalyst drivers and the legacy drivers for the 4250. The instructions said not to install the control center with the new drivers, and to install only the control center from the legacy driver package. Apparently that's supposed to enable some sort of swtich in the Vision engine that switches from using the 4250 to the 5470. Seemed odd, yet understandable. Still nothing. No hardware acceleration, still the wrong display resolution. No options other than CPU Power in AMD Vision.

Ok. For laughs let's try it the other way around. Nope. Same thing.

Device Manager shows 2 graphics adapters. The 5470 and Standard VGA adapter. When changing screen resolution in Control Panel I only have options for 800x600 and 1024x768, and the only graphics adapter available is Standard VGA adapter.

Advanced options has nothing significant. No options for refresh rates and only a link to the AMD control center that has no options but CPU power.

This is driving me insane. I really need to be able to use this computer, preferably within the next few hours (I'm running behind on a graphic design project).
October 26, 2013 11:45:52 PM

maybe a stupid question but, system restore?

ive always had much better luck using DevManView with viewing and removing drivers, even if you delete all of them and restart your computer it should put you back at square 1. amd has an autodetect for drivers, did that not work?
m
0
l
October 26, 2013 11:45:56 PM

Try turning off on board video in the bios.
m
0
l
Related resources

Best solution

October 27, 2013 12:13:22 AM

Thanks for the help/concern, guys, but I may have found a (not-so-ideal...) solution.

@TheMaudDib - While I didn't mention it, when I uninstalled the drivers each time I probably should have said reinstalled windows. I don't trust system restore that much, haha.

@Deuce65 - I checked that just now, but it seems there is no option for disabling onboard video. That is a bit odd, as I remember that from a notebook I had many years ago (ah, the XP/Vista transition days). Never thought of it as I got so used to using desktops that don't have onboard options.

The solution I found: Installing Catalyst 8. Yep, the old version from when this thing was manufactured. I only wonder if it's safe to try upgrading or if I'm stuck here due to some odd hardware configuration AMD just doesn't care about. If so, I think I may have to start another thread for that one.
Share
October 28, 2013 7:30:59 AM

georgiepiebob said:

@TheMaudDib - While I didn't mention it, when I uninstalled the drivers each time I probably should have said reinstalled windows. I don't trust system restore that much, haha.


Glad you got it figured out!
m
0
l
a b $ Windows 7
October 28, 2013 1:50:11 PM

I don't know if you tried updating driver manually through Device Manager but I would give this a lash.

Download these two files from driverscollection:

13-1_vista_win7_win8_64_dd_ccc_whql.exe

AMD_Catalyst_13.5_CAP1.05212013.exe.

When you have them, I would first uninstall the 5470 driver in the system and make sure that it doesn't appear in Device Manager. Uninstall from there if necessary. But don't restart yet.

Now I would run the 13-1_vista_win7 file but only let it get to the point where it has extracted all the files it needs.

I would then locate the extracted files on the disk in order to find out the path I will need to browse to those files.

When I know where installation files are, I would try and locate a folder that relates it to 64-bit or win7 or something. The required .inf file should be here.

Then I would select the Standard VGA Adapter in device manager and click on 'Update Driver'.

On the next screen I would choose Browse My Computer and then browse to where you think the .inf file is and select it.

Hopefully, Windows will use the information it has on available devices and will choose the drivers that are relevant to your system.

A: If this process succeeds in updating something, perhaps the correct name of the adapter appears in Device Manager, then I would Cancel the installation that I started to get at the extracted files and then I would restart the computer.

B: If this process failed to achieve an update, i.e., none of the extracted .inf files work, and Windows reports that it's using the best driver, I would go back to the installation program that is wait for me to press next and I would press next.

Then restart.

If A was the situation, I would then check out the graphics' functionality to see if that made any difference.

If the update through Device Manager had worked, then I would re-run the Graphics installation package. Possibly another restart and then I would install the second file I had downloaded, the smaller one; it appears to have something to do with settings.

m
0
l
!