Sign in with
Sign up | Sign in
Your question

Primary PCI-E x16 slot no longer detecting video cards after 7870 install attempt

Last response: in Motherboards
Share
October 27, 2013 8:01:06 PM

Greetings, I recently purchased a PowerColor 7870 Myst Edition to replace my 5770. When I attempted to boot the system with the 7870 installed, I got a beep code (one long three short) indicating that the system was not detecting a video card. Puzzled, I tried re-installing the 5770 back into the primary PCI-E x16 slot and I was greeted once again with the beep code. The card had been working perfectly in that slot not even 30 minutes prior!

I then tried installing the 5770 into my secondary PCI-E x16 slot (which runs at x4) and I was able to successfully boot. With the 5770 working again, I then swapped it out with the 7870 and while I no longer got the beep error code, the system would not post (the short beep indicating a successful post never happens). So, I'm back on the 5770.

My system is as follows:
PSU: 550W Antec Truepower 2.0
CPU: Phenom II X4 965
RAM: 4 GB DDR2
Mobo: ASUS M4A78 Plus
HD: two 320 GB drives

I've reseated/reinstalled the cards multiple times, cleared the CMOS, and reseated the other components in my system just to be thorough. I suspect that I will need a new motherboard, but I thought it'd be best to get more opinions before I spend the cash. Really puzzled about this and I'd sincerely appreciate any suggestions. Thanks!
a b U Graphics card
a b V Motherboard
October 27, 2013 8:33:22 PM

Could be that you fried your card with ESD when you installed it, rendering it and the slot inoperable.
m
0
l
October 27, 2013 8:45:38 PM

doubletake said:
Could be that you fried your card with ESD when you installed it, rendering it and the slot inoperable.


I'm always very careful to touch my case before I touch any of my components, so I don't think that's the cause. Then again, I've never lost a component to ESD so I wouldn't recognize it if it did happen! So, the card could be dead as well, darn. Unfortunately I don't have another system capable of installing the card so I've no way to test it.
m
0
l
!