Realtek HD Audio Intermittently Cuts out - Gigabyte GA-Z87X-UD3H

Hi all,

At a bit of a loss at the minute, would be really grateful for any help at all.

I’ve recently built a new PC, and have been experiencing minor but persistent audio issues with my onboard Realtek HD Audio device. My motherboard is a Gigabyte GA-Z87X-UD3H, and I’m running Win7 64-bit. Intermittently, (perhaps a couple of times an hour, sometimes it’ll go for hours without the issue) I experience a complete loss of audio for perhaps a second. I’ve noticed it mostly in games, but also during YouTube videos, so I’m assuming it’s a general issue rather than game specific.

I’ve also experienced a single (possibly unrelated) BSOD whilst playing a game. I’m not 100% confident the issues are related, but the BSOD was immediately preceded by a loss of audio, so I’m considering the possibility, and I’ve never seen the BSOD again despite many hours of gaming. For the moment, I’m trying to deal with the audio issues in isolation, and I’ll address the BSOD if it recurs.

I’m using a simple 2-speaker plus sub-woofer sound set up, plugged into the rear main out green jack. Sound works fine apart from the intermittent loss. I’ve tried the latest drivers from the Gigabyte website, and I’ve tried the ones that came on the disk. Issue is present either way.

I’m looking for any ideas / help people can offer for what diagnostic steps to take here – I’ve trawled the Event Viewer, and there does seem to be a few possibly-related information entries around the time of some incidents, very non-specific audio-mentioning things. The last time it occurred I also saw, in EventViewer, an information message titled ‘BlueScreen’, though there was no BSOD. Again, don’t know if this is relevant.


If I can’t resolve it I may opt for a dedicated sound card, but I’m worried that these issues are indicative of a more fundamental hardware problem, so I’d like to get to the bottom of them if possible.

Thanks in advance!

Nick
6 answers Last reply
More about realtek audio intermittently cuts gigabyte z87x ud3h
  1. Nick,

    You did not mention the drivers you installed to run the card. Perhaps reinstalling the drivers or updating the drivers will fix the problem.

    Win 7 & Win 8 have default drivers that work for most hardware, but they are not all encompassing.
  2. Thanks for the reply.

    Initially I installed the Realtek drivers from the disc which came with the motherboard, then I tried the latest Realtek HD Audio Drivers from the Gigabyte website for my specific motherboard. No luck either way.

    I'll try a re-install, though. Worth a shot, I guess, but I'm not confident :)
  3. You can try a repair of Win 7 as well. Don't opt for new install or any change in settings; but it may be the OS installation is buggy.
  4. Not the same model, but I also encountered the same problem with a Gigabyte using Realtek audio. I eventually realized that the problem seemed to come up whenever using certain hardware/temperature monitoring programs, such as SpeedFan. You could try terminating extra processes you usually leave loaded in the background, see if your motherboard audio's just not liking some of those.
  5. Also worth a try, I think - I do have a bunch of Gigabyte utilities running including EZTune stuff that does hardware monitoring. I'll remove it all, see if it makes any odds.
  6. I don't want to prematurely call this fixed, but doing a few things I've not seen the issue in a couple of hours of gaming since (though I don't think this is definitive). Just wanted to note down what I did in case someone else stumbles across the same issue and I forget to come back and log what I did:

    Unfortunately I was a bit unscientific and did all this at once (and not in isolation), so I can't tell what might be the effective step, but here goes:

    - In Realtek HD Audio Manager, in connector settings (the little folder), I disabled front panel jack detection. The thinking here was that perhaps the f_panel was faulty, and the occasional loss of sound was a false positive detection of headphone insertion in the front panel.
    - In 'Manage Audio Devices' I disabled everything that wasn't 'Speakers - Realtek HD Audio Device'.
    - I uninstalled EZTune, specifically to get rid of sensordetector.exe.

    I'll get a few more hours of gaming in before I call this definitively fixed, but I would normally have seen it by now.
Ask a new question

Read More

Realtek Motherboards Audio