Sign in with
Sign up | Sign in
Your question
Solved

Catalyst Control Center won'w open after installing Windows 8.1

Tags:
  • Windows
  • Catalyst
  • Windows 8
  • Graphics
Last response: in Graphics & Displays
Share
November 3, 2013 3:35:17 PM

I am not quite sure if i need to update it or something but after updating windows and i try to open CCC it pops up a notification "Catalyst Control Center cannot be started.
There are currently no settings that can be configured using Catalyst Control Center"
I am trying to open it to expand my screen to fit my monitor because the resolution is already at the highest. Can anyone help?
Thanks
-joe

More about : catalyst control center open installing windows

Best solution

a b * Windows 8
November 3, 2013 4:36:39 PM

Hey Joe,

Best bet would be to go download a fresh copy of CCC from the AMD website. Uninstall the existing one that doesn't want to open, reboot the machine, and when you're back in Windows, install the freshly downloaded copy.
Share
November 3, 2013 5:45:57 PM

The_Prophecy said:
Hey Joe,

Best bet would be to go download a fresh copy of CCC from the AMD website. Uninstall the existing one that doesn't want to open, reboot the machine, and when you're back in Windows, install the freshly downloaded copy.


It worked! Thank you Thank you! I did not think about trying that! Thank you!
m
0
l
Related resources
November 21, 2013 8:21:48 AM

joejoejoejoejoe said:
The_Prophecy said:
Hey Joe,

Best bet would be to go download a fresh copy of CCC from the AMD website. Uninstall the existing one that doesn't want to open, reboot the machine, and when you're back in Windows, install the freshly downloaded copy.


It worked! Thank you Thank you! I did not think about trying that! Thank you!


hi. i have the same problem. can you please post the download link for the new CCC software ? the card i have is the amd radeon hd 8730m. please help.
m
0
l
a b * Windows 8
November 21, 2013 8:26:24 AM

Here is the Driver Download Center link on the AMD website Pick your card and OS and it will give you the download you're looking for:

http://support.amd.com/en-us/download
m
0
l
July 2, 2014 7:29:39 AM

i did what The_Prophecy said .... i still have same same problem
m
0
l
September 4, 2014 11:22:43 PM

Fixed it by UN-installing everything AMD and restarting, (yet again). Downloaded and ran the AMD CleanUtility, (link below), then restarted, (yet again). Once the machine came to life again. I went straight to the AMDsite, proceeded to the drivers page, and downloaded the 14.7 beta driver pack. I installed the package, (yet again), (Making sure to UN-tick the AMD Gaming Evolve CRAP!). Then, I restarted, (you guessed it.., yet again).

When she came to the AMD Catalyst Utility started on it own!!! YAY!!!

(Granted it was last in the start-up list, but that is easily fixable with the proper utility to change your start-up order)!!
(Then, created a Restore Point!)

Good Luck!! hope this one helps!!

http://www.tomshardware.com/forum/newresponse/2272071
m
0
l
!