Sign-in / Sign-up
Your question

question about ahci mode on windows 8 with ssd

Tags:
  • SSD
  • Clean Install
  • Intel
  • Windows 8
Last response: in Windows 8
November 4, 2013 9:28:51 AM

So i did a clean install of windows 8 on my pc last night onto a intel 520 ssd. I did tests on it with as ssd and the score was ~ 400(ran it several times, ~240 read,~140 write. Board only supports sata2 not 3, so results seem fine.)
I can run all the functions on the intel toolbox(except secure erase of course). Checked and confirmed that trim is enabled.
What sort of confuses me is when i look under boot order in bios the ssd is listed as ide intel etc. And when i check my reged file startoverride is set to 3. I tried setting it to 0 and rebooting several times but it always set it back to 3(3 means ide and 0 for ahci i believe). I did change the error value in storahci to 0. Several other things ive tried
- made sure bios setting always had raid set to ahci, never changed it
- changing the sata port the ssd was plugged into
- changing the startoverride value and rebooting on safeboot minimal
- uninstalling the sata driver to let windows reinstall it on its own

And i did switch the raid setting to ahci in bios before clean installing windows 8 with all the drivers.

My bios and drivers are all up to date. Mobo is a msi 760gm p34. Any suggestions on what todo?

More about : question ahci mode windows ssd

a b * Windows 8
November 4, 2013 10:05:58 AM

I believe if you have already installed the OS under IDE in order to switch it to AHCI you need to change things within the registry, you will want to google that to be certain. The other option would be to change it to AHCI and do another clean install of the OS.
m
0
l
November 4, 2013 10:30:42 AM

Ive already stated i made the switch to ahci before the clean install...

So basically heres what i did, and let me know if i screwed something up during the process. Since it was a ssd i originally used for my laptop, i connected the ssd to the pc running with the hdd. I formatted the ssd there. Then i restarted the pc to switch the raid setting from ide to ahci. Saved and exited, then flipped off power to the pc. Unplugged all connections to my hdd and booted up the pc with only ssd and cd/dvd drives connected to sata ports. Then went through the process of installing windows 8 with the cd. After installation went back to bios settings to check if it was set on ahci and it was.

under device manager its listed as AMD sata controller and not amd (sata) ahci controller, unless this is normal.
m
0
l