Radeon HD 4300/4500

I have radeon HD 4300/4500 series graphics card, I'm trying to update the driver but it keeps coming up with installation pack error. I know that the card is a little outdated but it still works fine.
1 answer Last reply
More about radeon 4300 4500
  1. 4000 series cards are not supported by new drivers. There's nothing to update to.
Ask a new question

Read More

Radeon Graphics Cards HD Graphics