Sign in with
Sign up | Sign in
Your question

Horrible HDMI output R9 280x

Last response: in Graphics & Displays
Share
November 5, 2013 11:59:48 PM

I just went through an insane ordeal that started with me wanting a new graphics card and ended with a 16gbs of RAM, a SSD, a new Mobo and an r9 280x. I don't know how or what happened but it did.

In any case, I am running Windows 8.1 64 Bit, attempting to do so with HDMI after windows install it runs through the HDMI cable fine, albeit the usual no drivers low res. After driver install the HDMI output becomes like a bad acid trip in which you are wantonly thrust backward through time to the production of Yellow Submarine. Not my cup of tea.


(Sorry when I 'print screened' it it just looked normal)

But that is what the entire screen on any page looks like. Switching over to a DVI cable at 1920 x 1200 is a crisp clear picture. It is a fresh install of Windows 8.1 with the latest drivers. The cable is fine as it works fine before the drivers are installed

Thanks for any help offered; it is much appreciated!

Peter
November 6, 2013 5:08:46 AM

Yes sir, drivers are straight from AMD's site. The settings do not change from HDMI to DVI, but i double checked and that is not the issue.

The weird thing is that the 'Print Screen' I took with it all crazy looking looks fine after a reboot and into DVI. If it were a display adapter issue wouldn't the print screen looked all messed up too?

Oh and HDMI looked fine through my GTX 570 on this monitor.

Thanks again!
m
0
l
Related resources
!