Sign in with
Sign up | Sign in
Your question
Solved

SSD AHCI Problems

Last response: in Storage
Share
November 7, 2013 12:59:13 PM

Hello all. I've read through some other topics but none have offered any solutions for me yet so I thought I would start my own.

I've got an OCZ Vertex 4 SSD 256GB. Recently it was running Windows 7 with AHCI mode enabled in the bios.
I upgraded to Windows 8 (I did a fresh install after formatting the SSD). I left the SATA controller in AHCI mode in the BIOS the whole time. I have been running Windows 8 now for a few weeks or so with AHCI enabled and have had no problems until now.....

I was updating my GPU drivers and decided to see if there were any Motherboard drivers that needed updated while I was at it. I noticed there was a new BIOS for my Motherboard that was highly recommended if running Windows 8. So, I downloaded and installed it.

After the BIOS update, I noticed my whole system felt a little sluggish. I booted to the BIOS and noticed that everything was back at defaults. No problem. I went ahead and set my SATA controller back to AHCI and that is when I found out Windows would not even boot anymore when AHCI was enabled.

Motherboard: MSI 970-G45
CPU Phenom II X 55
Corsair RAM 2x4GB
AMD 7850

I tried the suggestion in this link but it didn't work.
http://www.ithinkdiff.com/how-to-enable-ahci-in-windows...

My SSD uses TRIM and greatly benefits from AHCI mode.

More about : ssd ahci problems

a b G Storage
November 7, 2013 1:05:42 PM

try and revert the bios back to the one that worked. The reason I don't flash a BIOS unless I need to, not just because. lol.
m
0
l
November 7, 2013 1:19:53 PM

Yeah. Me either, but this update was recommended since I was running Windows 8. I was expecting maybe a performance boost.

The problem is I can't revert back. The current version is 2.6 and my old version was 1.11. You can't go back to 1.xx once you've upgraded to 2.xx according to MSI. My only bet is to downgrade to the first version of 2.xx
m
0
l
Related resources

Best solution

November 7, 2013 2:00:22 PM

I resolved it by following the solution in this link
http://support.microsoft.com/kb/2751461

I thought I had already tried that solution, but went ahead and did it again and now my SSD boots fine with AHCI enabled. And boy the difference is very noticeable.
Share
!