Sign in with
Sign up | Sign in
Your question

Windows 7 stuck on disk.sys/ Custom built PC

Tags:
Last response: in Windows 7
Share
November 7, 2013 6:47:05 PM

Hello all,
I built this PC last year, worked perfectly fine up until last night. During the year i've used it i did 1 clean install of windows 7.

My specs are:
CPU: Core i5 3570k
Motherboard: Asus P8Z77-V LX
RAM: 4x4GB Corsair XMS3 1333Mhz
HDD:-120GB Intel Cherryville 520(Boot drive)(SATA6_Port1
-Intel Maplecrest 330 60GB ( SATA6_Port2; Storage )
-Seagate Barracuda 1TB 7200RPM SATA3 ( Sata 3_Port 1; Storage)
PSU: Rosewill Hive 550W
GPU:Asus GTX 550 Ti

-First thing i tried was to boot using "Last known configuration", and it just hangs at the starting logo, animation keeps going but nothing happens.

-Next, i remove my GPU and tried again

-Next, i popped in my Windows 7 CD and set my DVD drive in 1st boot priority. Hangs at windows logo

-Took out 3 out of 4 DIMMs, leaving 1 in slot A2, which is what is recommended for 1 DIMM setup in the MB Manual.

-Still without GPU and 3 DIMMs, i unplug my main SSD ( the 120GB with the OS installed on it), i try booting from the CD again. Same result.

-Tried setting SATA port configuration in the BIOS from AHCI to IDE, re did all these troubleshooting steps with the same result.

-I started toggling my hard drives by unplugging them...gave mixed results:
1.Trying to boot to the windows 7 dvd with both my main OS drive and second storage SSD, it just hangs at windows logo

2.Still, with only 1 of the SSDs plugged in, if i go to my boot mode options, i suddenly get the Repair Computer option...Brings me to Windows Computer repair, but both keyboard and mouse not working ( At this point i'm thinking 1 of my IRQs might be pooched? I don't know how to check for that though...)
And if i chose Safe mode, i get to the System Recovery screen, but keyboard and mouse still not working. ( Works fine in the Asus BIOS)(At this point, it went past Disk.sys when bootin in safe mode; It got to AVGIDSHA.SYS then it restarts to System Restore, but keyboard and mouse still don't work.

3.With 1TB HDD unplugged, and either of the SSDs plugged in, if i boot to the CD i get to what looks like the Windows 7 setup background, but nothing else.
4.With only the 1TB drive plugged in, it just hangs on windows logo instead of showing the windows 7 setup background like before with 1 SSD plugged in,. ( I highly doubt the drive is dead; I ear it spinning and it's not making any nasty sounds...)
I'm going to try and flash my BIOS to the latest version ( Currently on version 1902, there's version 2204 on the Asus website now) and i'll also try using a different DVD drive ( Will borrow 1 from work)

I don't care about losing my stuff on my OS drive; Both other HDDs detect fine, and don't seem to be having any prominent issues...Other than that i'm stumped.

If you have some suggestions, i really appreciate them, and thank you so much for going through my wall of text.

TL;DR: Tried a buttload of troubleshooting, with mixed, but not promising results. Ranges from hanging on windows starting animation; hangs on disk.sys in safe mode; Can't boot to win7 install CD;

I troubleshooted for about 20 minutes before starting to type this post..been about 4 hours, kept adding as i tried different things.


Update: As i was editing this, i noticed my cursor appeared on the Windows Start Repair Screen...it finished the repair "successfully", restarted, but nothing changed.
I'm now trying to see if my mouse will detect after a few minutes when booting using ( Repair your computer from Boot mode options)
Update: So my mouse cursor came up at the System restore screen...tried doimg a system restore to a restore point from 10/25/2013 ( Computer worked perfectly as of this morning apparently, i used it last night until ~11PM, then tried turning on this morning at 7:30AM)...No changes whatsoever....
November 8, 2013 2:52:52 PM

UPDATE:
Just got home from work, got a different USB key and flashed my BIOS. First try and i was able to fully boot in to windows ( Though the system restore i did actually did apply and restored to 10.25.2013..I'm re-installing windows 7 now to my 120GB SSD. Will then re-install my DIMMs, followed by GPU, followed by storage devices. Hopefully all goes well until the end :D 

Will say if it's resolved at the end.

UPDATE: So after flashing the BIOS, with only my main 120GB SSD plugged in i was able to fully install windows 7 with 0 errors. Once that was done i was added my 3 other DIMMs, booted up fine. Then i installed my GPU, continuing troubleshooting without the latest driver update. Once i plugged in my seagate HDD, it hung on the windows logo so i found my hardware problem.

Installed my drivers now and everything is running perfectly fine :D  I don't know why the USB i had didn't show up in Asus EZ Flash tool in the BIOS, but i couldn't gotten this fixed so much faster if i had another USB to try...
m
0
l
Related resources
!