Sign in with
Sign up | Sign in
Your question

AMD Catalyst Control Center launching problems

Last response: in Applications
Share
November 10, 2013 3:02:51 PM

After my PC short circuited from water damage and I had to replace all the hardware inside Ive noticed problems with the application "AMD Catalyst Control Center". Whenever I try and open it from the right click drop down menu or the taskbar the window appears for a second or two and then just closes itself and proceeds with a "host application has stopped working" error message. I have tried clean uninstalling my drivers for my GPU and reinstalling them to no avail. Also if its relevant after my PC short circuited I've noticed that some games stutter and freeze for a split second that didn't previously do that maybe thats somehow linked with the whole Catalyst Control Center/driver issues.

PC specs:
OS: WIndows 7 64bit
GPU: AMD Radeon HD 6870
CPU: Intel Core i5-3570K CPU @ 3.40GHz
Mobo: Asus P8B75-M LX
RAM: Corsair Vengeance 8GB
PSU: Cooler Master Extreme Power Plus 650W
HDD: Western Digital WD Caviar Black 2TB HDD

November 10, 2013 3:58:52 PM

Remove the existing install with revo uninstaller, and use the moderate option to clean up registry entries.

Then reinstall the CCC software.
November 10, 2013 5:20:56 PM

aford10 said:
Remove the existing install with revo uninstaller, and use the moderate option to clean up registry entries.

Then reinstall the CCC software.

Did this and no fix, I had a feeling this wouldn't work since i've already done an extremely clean uninstall with no traces of it in the universe then reinstalled it and that didn't work. This leads me to believe its a problem with another software like .net framework?
Related resources
November 16, 2013 1:08:27 PM


Tried it multiple times and then more, still no fix.... Thanks for looking for solutions and I apologize for being so hopeless :p  Is there anymore possible ways of fixing this??
November 16, 2013 1:25:37 PM

Have you tried it on a different local profile? It may just be some corruption on your profile.
November 16, 2013 1:42:25 PM

Would you mind walking me through how to do this?
November 16, 2013 9:16:58 PM

You can go to the control panel-->users and computers. Create another user account. You can then log off the computer as your account and then on as your new account. If the problem doesn't follow to the new user account, you can delete and re-create your account.
December 7, 2013 4:50:06 PM

I tried creating a new account and launching it but it still seems to be the same problem...Should I reinstall windows 7?
December 7, 2013 4:55:41 PM

That is certainly an option.
December 7, 2013 9:32:53 PM

Freshly reinstalled Windows 7 and all drivers and it still doesn't work, this is really irritating... I am desperate for an option here...anyone?
December 7, 2013 10:14:20 PM

Yep, definitely using version 13.9.
December 7, 2013 10:23:24 PM

Ok, then try going back to 13.8
December 7, 2013 10:49:25 PM

I can only find 13.10 and 13.11 on the site?
December 8, 2013 12:17:05 AM

I rebooted in safe mode and launched CCC and it said "There are currently no settings that can be configured using catalyst control center."
December 8, 2013 10:22:44 AM

I believe in safe mode it uses the default display driver, not the catalyst driver.

Instead of going back to 13.8, try upgrading to 13.11.
December 8, 2013 3:09:31 PM

I've tried using the 13.11 beta drivers and the problem still persists.
December 10, 2013 12:48:52 AM

Would the 13.4 drivers be suitable for a Radeon 6870?
December 10, 2013 4:16:50 PM

I didn't see that version listed for your video card, but the catalyst drivers tend to be universal for radeon video cards, so it should be.
!