Sign in with
Sign up | Sign in
Your question
Solved

Windows 8.1 power options corrupted

Last response: in Windows 8
Share
November 11, 2013 3:31:30 AM

For some reason Windows 8.1 power options on my notebook got really screwed up. First I tried to create a new plan, but couldn't, got this error:

"Your power plan information isn't available. Access is denied."


I found this guide of how to restore the default power schemes in Windows 7 forums, which applies to Windows 8/8.1 as well:

http://www.sevenforums.com/tutorials/950-power-plan-restore-default-settings.html

I run a command prompt as an Administrator and then entered powercfg -restoredefaultschemes in order to restore the default power plans, but it actually screwed the power options even more. Doing this simply deleted the 3 default energy plans. After this, when I attempt to create a power plan, I encounter this error:

"Windows can't save some of your changes to this plan's power settings - the system cannot find the file specified."

I even tried to duplicate the only existing power plan and rename it, but command prompt told me I did not have the necessary permissions. My account is an Administrator one.

Some user stated on that thread that Avast! 2014 might have messed with Windows 8.1 power options permissions, could it be true? I have AMD Catalyst Mobilty package installed as well (13.11 beta 9.2), but I don't believe it has anything to do with the issue.

Is there a way I can restore the power default schemes or the permissions to create power plans? It's actually the second time this has happened. The 1st time I ended up formatting the Windows partition due to another unrelated issue, but in the end it fixed the power options corruption. However, I don't think performing another clean install is a definitive solution, as the issue might return.

I hope someone finds a solution for this issue. Thanks in advance.

Info:

Notebook model: Dell Inspiron 15R-5537
OS: Windows 8.1 Pro x64
CPU: Intel core i5-4200U
GPU: AMD Radeon HD 8850M (Catalyst Mobility 13.11 beta 9.2 x64)
AV: avast! 2014 Free
a b * Windows 8
November 11, 2013 9:56:48 AM

First try running the sfc /scannow command from that administrative command prompt. Should replace that missing file needed to create the power plans.
m
0
l
November 14, 2013 1:03:49 PM

Thank you for the reply, but I think it was avast`s fault, I believe it was messing with permissions necessary to create power schemes. I read in avast forums that some users were facing the same issue, so I uninstalled it, entered "powercfg /restoredefaultschemes" on an elevated command prompt and rebooted. The permissions and default schemes were restored successfully.

I reinstalled avast! after this procedure and so far no issues with power options. By the way, Sfc /scannow didn't return any corrupted or missing files.
m
0
l
Related resources

Best solution

November 16, 2013 11:48:55 AM

FYI, maybe this is useful info: I don't have Avast but I'm also having problems with my power plan vs. GPU drivers. Samsung laptop with a Radeon card, 8500M HD, Win 8.1 64bit. Catalyst keeps crashing when I try to adjust the power plan and then the screen brightness controls stop working.
Share
May 5, 2014 7:20:52 PM

Trying perform a clean install and install OEM Intel HD Graphics. I can provide a link to a modded Catalyst which solves several issues.
m
0
l
!