Sign in with
Sign up | Sign in
Your question
Solved

[SOLVED!] "Bootmgr missing" appears when attempting to install windows 7 pro from a flashdrive

Last response: in Laptops & Notebooks
Share
November 13, 2013 6:24:20 AM

Turns out my flashdrive was bootable regardless of USB/DVD download tool giving me an error saying it was unbootable. Have no idea of why, but I read it was because the drive was ALREADY bootable. Installing W7 on my laptop as we speak. I am a happy camper!

So I'm trying to install W7 onto my Asus laptop from a flashdrive. The laptop came with W7 installed but I had to wipe it for a number of reasons. I'm not in possession of a W7 disk so I installed Vista temporarily since I was in possession of that disk as my desktop runs it. I dislike Vista and my laptop doesnt have internet because of it so I want to go back to W7.
I downloaded a Windows 7 Professional 64bit iso from here http://answers.microsoft.com/en-us/windows/forum/window... (it was the only place I could find this version without a service 1 pack), I never "officially purchased" W7, I had it preinstalled in my laptop and the sticker on the back has the key for it so I figured I'd just use that.
I followed these steps for creating a bootable flashdrive http://www.wikihow.com/Create-a-Bootable-Windows-7-or-V... the only thing I did different was use Rufus http://rufus.akeo.ie/ instead of the USB/DVD download tool because when I used it it told me it copied the files but couldn't make the flashdrive bootable. Rufus worked fine and did not give me any warning messages.
I followed all the steps accordingly; but when I get to the BIOS screen on my laptop to boot from the flashdrive, the boot tab does not give me the option of booting from a removeable disk. It looks like this:
Boot Configuration
UEFI Boot [disabled]
PXE ROM [disabled]

Boot Option Priorities
Boot Opion 1 [P1: MATSHITADVD-RA...]
Boot Option 2 [P0: ST9320423AS ...]

Hard Drive BBS Priorities
CD/DVD ROM Drive BBS Priorities
Delete Boot Option

(My windows vista disk is still inserted in the disk tray by the way)

In the Save and Exit tab however, my flashdrive's name appears in the boot selection menu

Boot Selection Menu
P0: ST9320423AS
SanDsk Cruzer Facet 1.26
P1: MATSHITADVD-RAM UJ890AS

I am able to select the SanDisk (my flashdrive) option, and I press enter, but my laptop gives me the message: BOOTMGR is missing
Press Ctrl+Alt+Delete to restart
_

Any suggestions to how I can fix this? Am I doing this wrong?Did I just complete miss something or is my laptop lacking in something? Any thing I can download to fix the problem?

I did Method 2 and beyond from my laptop while I used Rufus before that step on my desktop, could that have done anything?

Don't tell me to burn any disks, I am not in possession of any clean ones. I want to boot this from a flashdrive.

Best solution

a b D Laptop
a b Ĉ ASUS
a b $ Windows 7
November 13, 2013 7:59:29 AM

Download a new Windows 7 image of the same version that you use from HERE and download and use the MS USB installer tool and read the directions from HERE using the downloaded Windows 7 image. After installation, activate with your key.
Share
!