Solved

Computer will not recognize usb 3.0 in usb 3.0 but will recognize device in usb 2.0

Hello,
My computer will no longer recognize my 3.0 usb external drive when plugged into a 3.0 usb port. It will recognize it in a 2.0 port, and it will recognize 2.0 usb devices in a 3.0 port. I have tested the external drive using the 3.0 ports on my laptop and they work fine. The problem is not with the harddrives but something is wrong with my desktops usb 3.0.

I have updated the drivers for the external hard drive with no luck.

Please help

Edit-If you need the full specs of my computer in order to fix this problem, please feel free to ask.
11 answers Last reply Best Answer
More about computer recognize usb usb recognize device usb
  1. Hi, What about the USB 3.0 driver? Have you installed it?
  2. alexoiu said:
    Hi, What about the USB 3.0 driver? Have you installed it?


    The usb 3.0 driver that came with the motherboard? Yes it is installed. I also installed the usb 3.0 driver from the external hardrives website when the problem arouse to see if that would fix it. It didn't
    .
  3. What motherboard using?
  4. alexoiu said:
    What motherboard using?


    I am using a MSI FM2-A85XA-G65 FM2 AMD A85X (Hudson D4) HDMI SATA 6Gb/s USB 3.0 ATX AMD Motherboard

    here is the newegg site link:http://www.newegg.com/Product/Product.aspx?Item=N82E16813130663
  5. It should work. Try contacting MSI. See what they say.
  6. alexoiu said:
    It should work. Try contacting MSI. See what they say.


    Will do. Also I had similar problems with my motherboard drivers before and I fixed it by jumping the CMOS. should I try that again?
  7. I don't think it's a CMOS issue, but you can try it.
  8. Best answer
    I found the solution, I recently overclocked my computer using msi oc genie button and it worked fine initially, but when my hard-drive disappeared I turned back the overclock and wallah my hard-drive and usb's worked again. What the two have to do with each other I have no idea, but it worked.
  9. Thank you for the follow up.
  10. When you overclock you sometimes change bus frequencies in addition to the cpu multiplier. These new bus frequencies can cause devices to not be able to communicate on the bus anymore. I suspect this is what happened in your case.

    Also the first step in troubleshooting a problem on an overclocked system is to remove the overclock and see if the problem is gone as well.

    Nice job on finding the fix!
  11. Disabling xHCI in the BIOS did it for me
Ask a new question

Read More

External Drive USB Computers Storage Port USB3