Sign in with
Sign up | Sign in
Your question
Solved

Windows 8.1 all USB devices keep disconnect / reconnect with power saving off

Last response: in Windows 8
Share
November 16, 2013 5:17:19 AM

Windows 7 work perfectly but after windows 8.1 install i have this USB devices problems even with all power saving config at off. I disabled power save option in device manager and in power option cp. All usb devices disconnect / reconnect a lot . i pass more time fixing softwares related issue than doing anything else since i upgraded :p  i downgraded my laptop to windows 7 and i guess i will do the same with my desktop the feeling i have with this retail release is worse than a beta version more like a alpha...

please if you know how to fix this i need some help :)  have a nice day
a b * Windows 8
November 16, 2013 8:09:00 AM

Check for updated chipset drivers.
m
0
l
November 16, 2013 8:14:57 AM

i have the latest driver from amd. i tried some registry tweak in usb controls, im testing it right now. still no disconnect / reconnect for now... i hope it gonna work. Windows 8 seem to overide it own power setting. Disable the power saving in control pannel and device manager dont work.
m
0
l
Related resources
a b * Windows 8
November 16, 2013 8:17:57 AM

If the chipset drivers are completely updated, another possible solution would be a BIOS flash. Check your BIOS version and see if there are any updates available.
m
0
l
November 16, 2013 8:31:57 AM

bios is the latest too
what i tried is to force disable selective suspend, i added the enableselectivesuspend 0 dword key for every usb hub entry.
ex : hkey_local_machine\system\curentcontrolset\enum\usb\root_hub\4&116187d3&0\device parameter -> enableselectivesuspend 0

the parameter was not set for some of my usb port. still no disconnect after that
m
0
l
a b * Windows 8
November 16, 2013 8:40:55 AM

Strange that it wouldn't have set those keys globally for all hubs after you turned the Selective Suspend option off in the power profile.

I have the option enabled on my main desktop system running Windows 8.1 though and don't have this issue. Did you do a fresh install of 8.1 when you set this system up? Or was it an upgrade from Windows 8?
m
0
l
November 16, 2013 8:48:42 AM

yes it was a fresh install. my laptop have the same os with amd chispset and dont have the issue. I have read about others having the same problem with selective suspend even with completly different chipset. at least it work now. i hope this can help others people with similar issue. thanks for you reply it appreciated :) 
m
0
l

Best solution

December 11, 2013 4:23:24 PM

Had the same problem with my external hard disk - however turned out this guys managed to come up with a registry hack that works great for me and other people as well:

http://blogs.msdn.com/b/usbcoreblog/archive/2013/11/01/...
Share
April 17, 2014 5:05:36 AM

Can you describe the registry tweaks? I thought I had resolved the issue with only two of my four USB 3.0 Ports in Wndows 8.1 by uninstalling all drivers related to USB and rebooting, but after a day or so, it started disconnecting, reconnecting again about every half hour.
Thanks

stonebob said:
i have the latest driver from amd. i tried some registry tweak in usb controls, im testing it right now. still no disconnect / reconnect for now... i hope it gonna work. Windows 8 seem to overide it own power setting. Disable the power saving in control pannel and device manager dont work.


m
0
l
April 17, 2014 5:25:27 AM

After reading through this article,it says that it is no longer necessary to hack the registry, just to download MS Update KB2911106. However, when I attempted to do that, it told me that it was not relevant to my Windows 8.1 computer, so, back to square 1.

project_blazar said:
Had the same problem with my external hard disk - however turned out this guys managed to come up with a registry hack that works great for me and other people as well:

http://blogs.msdn.com/b/usbcoreblog/archive/2013/11/01/...


m
0
l
!