Solved

GTX 670 SLI issues

My system:

i7: 3820
Asus rampage formula IV X79
16gb ddr3
Windows 7 64bit (does not have sp1 or later)
Corsair Hx 1050
2x Gigabyte GTX 670 in sli

Issue:

This has been an on going issue that I have attempted to solve in the past, but I have never solved it & I have been living with it for over a year & now i'm sort of tired of it.

Simply my GTX 670 SLI will not use over 50% utilization on both in SLI in most games. In some games I can get close to 100% but in the fast majority of them I don't such as GW2, Final Fantasy XIV & most recently Battlefield 4.

When SLI is disabled, the system uses 99% of the GPU, but when it enable it I get about 45-48% use which sometimes dips down below 20%.

I have tried all the searchable solutions to this including the settings in the control panel for maximum performance etc. I have updated my drivers, both lazy method & with a driver sweeper. I have re-installed windows 7 a few times & problem still exists.

Things I have not tried:

1. Hitting it with a hammer.

Seriously:

1. I have not tried a BIOS update on my cards, i'm very new at this & I'm not sure if it will help
2. Should I update Windows 7 fully? Will this actually help because it will be an investment if you get what I mean.
3. any other suggestions?


I'm also debating just selling the 2 cards & going with a single GPU solution so I don't have to deal with this anymore.

Any help / tips is appreciated.
3 answers Last reply Best Answer
More about gtx 670 sli issues
  1. How are you getting that 50% number? What program? And is that processing load or memory usage?

    Anyway, if you have vsync on it's probably capping your cards at 50%, which is good. Your system is likely overkill for you monitor(1080p?) and it's trying to keep your frame rates under control.
  2. wdmfiber said:
    How are you getting that 50% number? What program? And is that processing load or memory usage?

    Anyway, if you have vsync on it's probably capping your cards at 50%, which is good. Your system is likely overkill for you monitor(1080p?) and it's trying to keep your frame rates under control.


    I'm using EVGA Precision X & the 50% is GPU utilization.

    I'm using a 144 hz monitor and i'm trying to get my frames at or above 120. Vsync on or off does not make a difference in terms of the gpu utilization. I have also set my monitor to 120hz and 144hz with same results. With the cards at 40-50% gpu utilization each on low i'm constantly dipping well below 70fps and an occasional < 30 when the card dips to about 20% utilization.

    Crysis 3 had the same issue and I found a time resolution program which solved the issue for the most part (85-95% utilization), but it only seems to work for Crysis 3.
  3. Best answer
    Ok, that bit of info was informative/helpful. You should not be getting low fps. Under 30, ya I see why your "pissed off"(hammer, lol).

    There are many threads on this subject. Appears your not alone. I just can't find a definitive answer. (as I realize now, I don't know)
    https://www.google.ca/#q=SLI+50%25+utilization
Ask a new question

Read More

Gtx SLI Graphics