Solved

unistalled catalyst control center and related drivers, now there is no display

***solved it was a bad hdmi wire that simulaneously went but works on other devices
I was upgrading from a 6670 to a MSI R9 270x. After I put in the new card windows started fine and then after installing drivers the system tried to reboot but windows kept crashing. So i put the 6670 back in and attempted to unistall the catalyst control center and its drivers so I could do i clean reinstall with the R9 270x. However after unistalling the catalyst control center and its amd drivers neither card is showing any display. Please help me out as this is my first build.
here are my current specs
UPDATE - I Still am receiving audio as i can hear the windows start up
MOBO http://www.amazon.com/gp/product/B00B9BDB14/ref=oh_details_o01_s01_i01?ie=UTF8&psc=1
CPU http://www.amazon.com/gp/product/B009O7YORK/ref=oh_details_o02_s00_i00?ie=UTF8&psc=1
PSU http://www.amazon.com/gp/product/B0092ML0OC/ref=oh_details_o01_s01_i04?ie=UTF8&psc=1

Since this was solved with a new hdmi wire I am going to randomly choose a reply below to shoe the solution as solved although the actual solution was a new hdmi cord.
7 answers Last reply Best Answer
More about unistalled catalyst control center related drivers display
  1. Best answer
    How did you uninstall the drivers? Did you use the amd uninstall utility?
  2. seezed said:
    How did you uninstall the drivers? Did you use the amd uninstall utility?


    I ran the catalyst control center setup.exe and instead of install I selected unistall and hit next and i believe the next screen asked if i wanted to unistall all related drivers, files and etc.
  3. Did you remove the drivers completely with driver sweep after you uninstalled it?

    Usual approach I take:

    Is uninstall with utility - restart - Sweep ATI drivers with Driver Sweeper - Restart - Install Fresh Drivers.
  4. seezed said:
    Did you remove the drivers completely with driver sweep after you uninstalled it?

    Usual approach I take:

    Is uninstall with utility - restart - Sweep ATI drivers with Driver Sweeper - Restart - Install Fresh Drivers.


    after I unstalled with utility the pc went to restart but no display so I am not able to Sweep ati drivers with driver sweeper
  5. fbondiskey said:
    seezed said:
    Did you remove the drivers completely with driver sweep after you uninstalled it?

    Usual approach I take:

    Is uninstall with utility - restart - Sweep ATI drivers with Driver Sweeper - Restart - Install Fresh Drivers.


    after I unstalled with utility the pc went to restart but no display so I am not able to Sweep ati drivers with driver sweeper


    Wait, so you have no display at all and can't see the screen? Or is it using integrated graphics?
  6. sora said:
    fbondiskey said:
    seezed said:
    Did you remove the drivers completely with driver sweep after you uninstalled it?

    Usual approach I take:

    Is uninstall with utility - restart - Sweep ATI drivers with Driver Sweeper - Restart - Install Fresh Drivers.


    after I unstalled with utility the pc went to restart but no display so I am not able to Sweep ati drivers with driver sweeper


    Wait, so you have no display at all and can't see the screen? Or is it using integrated graphics?


    No, there is no intergrated graphics on this mobo. After I unistalled drivers the computer needed to reboot and after shutting off to reboot i have no display when powered back on. so there is no display at all with either the 6670 or the r9 270x
  7. So I eventually tried another hdmi cord, now both cards are working fine. What are the odds my hdmi cord would go while my computer is restarting
Ask a new question

Read More

Windows Drivers Displays Catalyst Graphics