Sign in with
Sign up | Sign in
Your question
Solved

Netgear N150 WNA1100 USB Adapter Issues

Last response: in Wireless Networking
Share
November 18, 2013 8:08:54 AM

Hello there, I doubt this is the right place for my adapter, but I have a Netgear N150 Wireless USB adapter (WNA1100). I am running it on Windows 7. I've been using it quite successfully for the last year and a half when it stopped working suddenly. I figured I had to update it and when I went to install it, I got a Windows message from the Program Compatibility Assistant stating that I needed to install a Digitally Signed Driver for this product. I've looked every where and cannot find anything on this, so I am pretty much dead in the water with my laptop.

Has anyone had any issues like this and how did you over come it? I'm ready to pull my hair out.
November 18, 2013 8:18:33 AM

Hi, this doesnt look like a major problem.
I'm gonna tell you the basic stuff.
Try installing the drivers from official site.
http://downloadcenter.netgear.com/en/product/WNA1100

after downloading disconnect the device and install the drivers.
Restart if needed.
Then connect the device again.

If you have already done these, then you need to check the status in the device manager. Then I'll see if I can help further.
GoodLuck.
m
0
l
November 18, 2013 8:49:21 AM

Thanks for the help. I did everything you said to do and it states this:

"Windows requires a digitally signed driver. A recently installed program tried to install an unsigned driver. This version of Windows requires all drivers to have a valid digital signature. The driver is unavailable and the program that uses this driver might not work correctly. Uninstall the program or device that uses this driver and check the publisher's support website to get a digitally signed driver."

So yeah, I'm confused. :/ 
m
0
l
Related resources
November 18, 2013 9:06:55 AM

Okay. I am answering with my experience. Try uninstalling this device from the device manager. And select uninstall drivers and stuff. Then reconnect it again and let windows install the driver itself.
Also try connecting to another port.
And if u are warned that its not digitally signed, but there's an option to install anyway, choose that. See if it works. I'll reply back after about 14 hours now. Maybe an expert may reply. But try these until an expert shows up. I hope this works.
m
0
l
November 18, 2013 9:13:03 AM

Thanks, Karan...I'll try!

So I did as Karan mentioned and Windows won't install the driver by itself. So that's out. I saw somewhere about disabling signature verification:
Disable signature verification of drivers:

(Go to Start Menu > Run and type the following command:
bcdedit /set nointegritychecks ON
If the Run command is unavailable in start menu, please refer to this FAQ
Restart the PC and install the unsigned driver
Note that it is highly recommended to enable the signature verification of drivers
Go to Start Menu > Run and type the following command:

bcdedit /set nointegritychecks OFF
Restart your PC)

I tried that but it didn't seem to work, unless I am typing the stinking command in wrong. :/  I tried doing this: in the Run command, I typed bcdedit, hit enter, the little black window appeared and quickly went away so I could not do anything at all. I guess this option is out for me.

UPDATE:
Well, the PCA also gave me this after the signed driver stuff:
Driver:Atheros Security NDIS 6.0 Filter Driver
Service: JumpStart Wireless Filter Driver
Publisher: Atheros Communications, Inc.
Location: C:\Windows\System32\drivers

Is this what is keeping me from installing it correctly?

m
0
l

Best solution

November 18, 2013 10:19:48 PM

Okay, what you said about window disappearing quickly is normal. It is just executing the command.
And "bcdedit /set nointegritychecks ON" will disable the verification.
Which one did you try? The ON or OFF ? Also make sure to restart after doing it.
And PCA I suppose you are referring to Panda Cloud? I dont know about it but if it allows disabling then do it.
Share
!