Sign in with
Sign up | Sign in
Your question
Solved

My USB ports aren't working

Last response: in Components
Share
November 18, 2013 8:15:01 AM

Hi there,

My USB ports aren't working. This started yesterday whenever my computer would go to "sleep" i could not get it to come back by moving my mouse or pressing a key on my keyboard, i had to restart it completely. I tried the one's in the front, and in the back.

However when my computer is running, my Mouse/Keyboard,etc work fine that are connected to my USB ports.

But then when i try to put my iphone charger into the USB slot, it won't load up or charge my iphone.

I went into the device manager to look for a ? or ! in yellow but there isn't anything except "HID-complaint consumer device" but when i tried to update that it said it was up to date.

Another thing is when i tried to do Windows Updates, a lot of them failed yesterday.

This includes:

- nVidia - Graphics Adapter WDDM1.1, Graphics Adapter WDDM1.2, Graphics Adapter WDDM1.3, Other Hardware - Nvidia Geforce GTX 660

- C-Media Inc. - Audio Device - USB Audio Class 1.0 and 2.0 DAC Device Driver

- Intel - Other hardware - Intel (R) Smart Connect Technology Device

- Intel - Other hardware - Intel (R) Management Engine Interface

- Intel Corporation - Graphics Adapter WDDm1.1, Graphics Adapter WDDM1.2 - Intel(R) HD Graphics 4000

Also another issue i'm having is sometimes when i shut down my computer, it stays on "Computer is shutting down..." and never shuts down and i have to manually turn it off.

Any help would be greatly apreciated, im worried it might be the motherboard.

More about : usb ports working

November 18, 2013 8:16:51 AM

I'm currently running a Windows Fix it for USB devices, but its been "Scanning for hardware changes" For 30 minutes now
m
0
l

Best solution

November 18, 2013 8:29:28 AM

Have you tried turning off the computer, and unplugging it, then press and hold the power button for ~10 seconds, plug it back in and turn it on. It could be that there is some static electricity built up causing issues.
Share
!