Sign in with
Sign up | Sign in
Your question

1TB Western Digital Hard drive says needs format but already has been and has over 900GB of data on

Last response: in Storage
Share
November 18, 2013 12:56:30 PM

Have now recovered data from my o/s HD and now need to recover the main internal SATA storage one both became unuseable after problems i had, when I insert the 1TB internal one on a HD device that converts it to a USB drive it does not show any files and says needs formating, but that would surely make problem worse, recuva and find and mount do not find anything, is there any other programs i can use or should i format it and then use a format recovery tool such as the remo one although that is only trial version are their any freeware one i could try ? ( have also tried the HD internally connected but still says needs formating )
a c 812 G Storage
November 18, 2013 4:00:04 PM

Reover the partition. I use testdisk for this task but there are other programs available to do the same thing. I would think find and mount would work for you as well.
m
0
l
November 18, 2013 4:42:26 PM

thanks shall try test disk tomorrow

Findandmount didn't work
m
0
l
November 21, 2013 3:34:08 PM

Thanks couldnt access via motherboard but shall have another go when get more time

test disk came up with loads of options to partition but was not sure so cancelled it

if i partition the drive i thought doesnt it format it as well thus loosing the data ?

have tried the remo trial version that finds a few things but not much

so no point buying the full one

shall try the eassos free prog


m
0
l
!