Sign in with
Sign up | Sign in
Your question

1st time building a custom PC here. I got my parts yesterday and out each part together. When finished, I turned it on but the

Tags:
Last response: in Systems
Share
November 20, 2013 11:17:36 AM

I need help with my problem.
November 20, 2013 11:20:14 AM

We need a full list of your parts and the problems you are having.
November 20, 2013 11:43:22 AM

Motherboard- Asus Gryphon Z87 LGA 1150
Ram- Corsair Vengeance 8gb
Power supply- Corsair CXM seires CX600M 600W ATX12V v2.3
Cooler video card- EVGA SuperClocked 02G-P4-2765-KR GeForce GTX 760 2gb 256-bit GDDR5 PCI
CPU- intel Core i5-4670K Haswell 304GHz LGA 1150 84W Quad core
Water/liquid CPU cooler- Corsair Hydro Series H100i
Hard drive- Seagate Barracuda ST1000DM003 1tb
SSD- Samsung 840 EVO MZ-7TE120BW 2.5 120gb
Related resources
November 20, 2013 11:44:18 AM

What problem are you having?
November 20, 2013 11:44:29 AM

tiny voices said:
We need a full list of your parts and the problems you are having.


opps I forgot to reply but I post an answer as a reply.. Sorry about that!
November 20, 2013 11:56:18 AM

tiny voices said:
What problem are you having?


The problem that I having with this build is when I turn on the power button on the case, it turns on for a brief second and then it turns back off then on and then off and repeats the process. I have my case open and still trying to find the problem.. I could take pictures if you want to help you help me.
November 20, 2013 12:33:13 PM

tiny voices said:
Follow this guide to make sure EVERYTHING is connected properly.

http://www.tomshardware.com/forum/261145-31-perform-ste...


I think I may have found the problem. I am trying to send you a photo so you can see. I am not good with explaining and being descriptive.
!