Sign in with
Sign up | Sign in
Your question

AMD Radeon R9 270x dvi no signal found

Last response: in Graphics & Displays
Share
November 20, 2013 12:15:37 PM

Greetings all! I recently purchased the following items for a custom build:
Motherboard: MSI Military Class II: 970A-G46
CPU: AMD FX 6300 3.5 GHz
Video Card: AMD Radeon R9 270x
Power supply: Corsair CX 500 (500 Watt)
Dual Monitors: Acer G236 HL
USB Logitech keyboard
Mouse: E-3lue Mazer type R
HDD: 1TB Sata OEM

Lights on motherboard come on, case fans, cpu fan, as well as video card fans turn on. DVI connections message "no signal found". Using stock DVI-D cables that came with monitors. Tested VGA cable on HP laptop so I know that the monitors are functioning. Using MSI slot on motherboard for graphics card.

Am I using the correct setup?
Could the video card be DOA?
a b V Motherboard
November 20, 2013 12:25:42 PM

Use the DVI port on the video card, not the motherboard.
m
0
l
a c 82 V Motherboard
November 20, 2013 12:26:19 PM

MSI slot? o.O
I suppose you meant PCIe x16 slot.

The most frequent mistakes are:
1- monitors plugged in the wrong connections (motherboard instead of GPU)
2- GPU not fully seated into the PCIe slot
3- missing auxiliary PCIe power connection(s) from the PSU to the GPU
m
0
l
Related resources
a b V Motherboard
November 20, 2013 12:32:49 PM

Thanks for clarifying ThalionV, the way it was worded seems otherwise. InvalidError listed some very common mistakes I would look at those first.
m
0
l
November 20, 2013 12:38:58 PM

InvalidError said:
MSI slot? o.O
I suppose you meant PCIe x16 slot.

The most frequent mistakes are:
1- monitors plugged in the wrong connections (motherboard instead of GPU)
2- GPU not fully seated into the PCIe slot
3- missing auxiliary PCIe power connection(s) from the PSU to the GPU


You're right InvalidError, I meant PCIe x16 slot.
I've re-seated the graphics card several times, ensuring it was connected properly. The card is receiving power from the PSU using two PCIe power connectors and the fans do indeed run.
m
0
l
a b V Motherboard
November 20, 2013 12:51:10 PM

Do you have another system to test this graphics card on? Does the motherboard have onboard graphics? if you remove your video card does it boot up?
m
0
l
!