Solved

Gigabyte R9 280X with no sound through HDMI

just like the title say, there is no sound coming out of the HDMI port of that card..

I dont know if thats normal but AFAIK HDMI carries sound data.

I tried almost everything but cudnt get it to work.

i have an asus xonar phoebus which is hocked up to my headphone and im connecting my 27" monitor (gaming) through dual-link DVI and my 46" (media) through HDMI.

i tried activating each port separately but no luck.

please help
11 answers Last reply Best Answer
More about gigabyte 280x sound hdmi
  1. Have you tried changing the output device to use the HDMI just look in your system tray and open the audio settings. And yes HDMI cable carry sound as well as video i think up to 7.1
  2. CNCSIT said:
    Have you tried changing the output device to use the HDMI just look in your system tray and open the audio settings. And yes HDMI cable carry sound as well as video i think up to 7.1


    it doesnt appear there, i even tried a different cable.. nothing!
  3. It should be listed as AMD HDMI output under audio devices.
    Did you install the HDMI audio drivers when you installed the graphics drivers? They are included in the software suite but if you did custom install you might have left them out...
  4. Kari said:
    It should be listed as AMD HDMI output under audio devices.
    Did you install the HDMI audio drivers when you installed the graphics drivers? They are included in the software suite but if you did custom install you might have left them out...


    well that i didnt try.. altho i installed the 13.11 beta driver from AMD site which should have those drivers i guess.. lemme check that and get back to u

    update: it says its already installed.. i did clean uninstall it and install it 2 or 3 times before when i had trouble with my CFX setup and the problem was there all the time but i didnt have time to check at that time.
  5. What are you running the HDMI to? is it a receiver? if so most receivers allow you to change the input devices for each input channel for instance you may have input 1 set to use HDMI for video but to use Optical for the sound.
  6. CNCSIT said:
    What are you running the HDMI to? is it a receiver? if so most receivers allow you to change the input devices for each input channel for instance you may have input 1 set to use HDMI for video but to use Optical for the sound.


    no, its a samsung smart tv
  7. anyone knows what to do..

    please.. im using shitty stereo speakers while my 7.1 home theater is sitting there collecting dust
  8. So you have your headphones connect to your sound card for when your gaming and the like on your monitor, but you want to watch media on your TV and you want to carry the audio through the HDMI to the TV? So there is a 7.1 system connected to your TV. You should be running the audio directly to the sound system instead of through the TV if thats the case. When you are playing media on your TV do you still get sound on your headphones? This is still sounding like a device issue to me those audio devices can be quite finicky sometimes im thinking its still trying to output to your sound card. try disabling it in your audio devices and then set your hdmi to default.
  9. Best answer
    Your set up is a little different, but I had a similar problem where audio wasn't being sent across HDMI. What I did to fix it was Disable the Realtek HDMI Output in the sound setting (Start -> Control Panel -> Sound), then restarted. After the reboot if you open that menu you will see your tv's model number as one of the AMD audio devices (previously called "Digital Display Audio").

    Hope this helps.
  10. the_caesar said:
    just like the title say, there is no sound coming out of the HDMI port of that card..

    I dont know if thats normal but AFAIK HDMI carries sound data.

    I tried almost everything but cudnt get it to work.

    i have an asus xonar phoebus which is hocked up to my headphone and im connecting my 27" monitor (gaming) through dual-link DVI and my 46" (media) through HDMI.

    i tried activating each port separately but no luck.

    please help


    in the sound settings playback tab righ click show disabled decices, you should see your tv there, enable it. worked for me.
  11. Just want to add ... little late to the game. I ran into the same situation with a Sapphire Dual-X edition of this card. I attempted ad nauseam to fix based on the rec's given above to no avail. No display output was showing up in control panel > sounds.

    If you're like me, make sure the AMD HDMI drivers are installed. My problem may have come about from the fact that I downloaded the drivers from Sapphire's website, rather than using the disk. I do not presently have an optical drive in my Mini ITX build.

    Go to control panel > device manager > sound, video and game controllers. You need to make sure AMD High Definition Audio Device is updated. I was not keeping track of things when troubleshooting (my apologies), but the driver was not located in Sound, video and game controllers. I believe I found it in Software devices. Update the driver and it will show up where it needs to go.

    My display audio appeared in the control panel > sound menu without a restart.

    GL HF! Hope this helps someone.
Ask a new question

Read More

Port Gigabyte HDMI Graphics