10 month old system does not boot(yes fans, no power led, no beep)

I've been using my system for 10 months or so for now.
It had worked well until yesterday, when it suddenly refused to boot.

When I press the power button, the following stuffs happen :
- All fans go up (PSU, case, GPU, CPU).
- Any USB stuff gets powered up.
- The power LED on the case does not light up.
- No beeps can be heard.
- Screen is blank (No Signal message, then monitor goes into sleep mode).
- ODD seems to be powered : it opens when I press the button on the ODD.
- HDD seems to be powered(basic rotation sound) but the system is not reading from it.
- System does not respond to any keyboard input.
- System does not respond to reset button or simple power switch press.
- Requires long press on power switch to turn off.

I have tried the following :
- Pull out power cable, press power switch to remove residual electricity, plug in, power on.
- Remove all USB stuffs and try again.
- Remove graphic card & RAM and try again.

And combinations of above.
There was no change in the problem.

Is there anything that I can do to pinpoint the problem?
I am suspecting CPU or MOBO, but I would like some confirmation before ripping the system apart and sending the parts for A/S.

My mainboard is MSI B75M-P45.
My CPU is i5-3570.
1 answer Last reply
More about month system boot fans power led beep
  1. What model of PSU do you have? Our troubleshooting checklist was created to troubleshoot this type of problem. Perform all the steps in the checklist and let us know how it goes.
    "No POST", "system won't boot", and "no video output" troubleshooting checklist
    "No POST", "system won't boot", and "no video output" troubleshooting checklistThis checklist is a compilation of troubleshooting ideas from many forum members. It's very important to actually perform every step in the checklist if you want to effectively... Read More
Ask a new question

Read More

Power Boot LED Monitor Boot Failure Systems