Sign in with
Sign up | Sign in
Your question
Solved

Can't get G.Skill ram to run at advertised speed on p67 mobo

Last response: in Memory
Share
November 22, 2013 6:17:54 AM

I recently upgraded my ram to a 16 gb (2x8gb) kit from G.Skill and can't get it to run at its advertised speed, which is 1866mhz. I can load xmp profile 1 and have it running at 1600. I previously had a Ripjaws X 2x2gb kit running successfully at 2133 mhz @ 1.6v on this mobo and it was stable since I got it in 2011.

My mobo is a Gigabyte GA-P67A-D3-B3 Rev 1.0 running on F7 (newest) firmware. I have an i7-2600k that is currently not overclocked.

XMP profile #1 loads fine but #2 fails. I've tried manually setting the timings in the bios but that also fails. Not sure if I am doing it wrong, though.

The new ram in question is Ripjaws X F3-1866C9-8GXM. One odd thing I've noticed is that cpu-z is reporting the xmp-1866 timing as 9-11-9-29 while the packaging has it listed as 9-10-9-28. Not sure if this indicates a problem. I've tried manually setting both speeds at 1.5v.

Best solution

a c 131 } Memory
November 22, 2013 6:31:05 AM

Try them at 1.55v, and bump VCCIO up .1V and see if that fixes things. Use the 9-11-9-29 timings first and try the others if youy get it stable (there will be very little difference between the two timings)
Share
November 22, 2013 6:53:30 AM

Did not mean to click that as solved, unfortunately the above response also didn't work.
m
0
l
Related resources
a c 131 } Memory
November 22, 2013 7:01:36 AM

That's odd, just for arguements sake (rarely works but has once or twice for me) swap the sticks around and try again.


Additionally try each stick by itself to see if one will boot and perhaps the other not at 1866. Could be one stick that doesn't like the speed.
m
0
l
November 22, 2013 7:19:36 AM

Supahos said:
That's odd, just for arguements sake (rarely works but has once or twice for me) swap the sticks around and try again.



Holy crap, that actually worked. Thanks!
m
0
l
a c 131 } Memory
November 22, 2013 7:23:46 AM

its not common, but sometimes there is a leader and follower stick (for lack of a technical term), I'm sure they only test them in one order and if it works they ship them. Glad that actually fixed it for you :)  guess I earned my Solution anyway lol
m
0
l
!