Solved

Just finished building my first gaming pc. Booted it up and no display on monitor.

I hit the power button for the first time and the power light did come on, but nothing is on the monitor. Checked out the insides and the graphics card and heat sink fans are spinning. The LED on the motherboard is on, but no display...I'd appreciate any help! Thanks!
3 answers Last reply Best Answer
More about finished building gaming booted display monitor
  1. Best answer
    Here is a really good checklist to use. Some of them will seem obvious, but double check them anyways. Sorry to hear you're having troubles, and I hope they resolve soon!

    http://www.tomshardware.com/forum/261145-31-perform-steps-posting-post-boot-video-problems
  2. jimthenagual said:
    Here is a really good checklist to use. Some of them will seem obvious, but double check them anyways. Sorry to hear you're having troubles, and I hope they resolve soon!

    http://www.tomshardware.com/forum/261145-31-perform-steps-posting-post-boot-video-problems


    Hi thanks for responding! I did find that checklist and I discovered that I've made a pretty newbie mistake. I didn't plug anything into the socket next to the processor, the 8 pin one (number 2 on that list). I didn't get a cable that has 8 pins, all I have was the 6 pin pci-e cables I got with the power supply. Is there some way to make that work?
  3. Your PSU likely has at least one 4pin CPU connector, you can try with that plugged into the 4 pins closest to the CPU.
Ask a new question

Read More

Monitors Power Graphics Displays