Sign in with
Sign up | Sign in
Your question

SAPPHIRE AMD R9 270X issue

Last response: in Graphics & Displays
Share
November 25, 2013 2:15:13 PM

So im having really bad luck at the moment with my pc, given wifi and printer issues, my tablets screen failing, laptop screen burning out etc..

I finally upgraded my old XFX AMD HD 4890 card to a SAPPHIRE AMD R9 270X Vapor-X OC card.
Went to install it a few days ago, swapped the cards fine, put everything back together, powered up the pc..so far so good..
But then I had issues getting the PC to actually recognise the card. For ages, it would only see it as a 'standard VGA graphics device' with basic display. Eventually I did get it to recognise it as a R9 200 series card, however it wasnt seeming to work correctly. None of the details ive found on the pc, either through gpu-z or device properties seem to record it as having any memory available. GPU-Z is reporting it as being way way underpowered.

I also cant seem to get any better display than standard display properties, and AMD catalyst control center refuses to run saying theres nothing that it can configure, so cannot be started.
Its almost like its not powering up enough to provide full features and is acting like a very low end card.

So I had to go back to my old 4890 card for now, which is using the same 2x6pin power cables so doesnt seem to be a power issue from my psu, which is 1000W.
But, Catalyst Control center still refuses to run now (ran fine before I tried new card), and cant seem to get any decent settings out of it. Attempted to run a game ive been playing for months fine, but it did not like it at all now!

Any ideas whats up?
Tomorrow as im off work, the plan is to gut the display drivers again, and try once more.

My system is:
Intel i7 950 cpu (3.06ghz)
24gb RAM
3Tb HDD space (3x1Tb drives)
1gb AMD 4890 GPU
1000W PSU

More about : sapphire amd 270x issue

Related resources
November 26, 2013 7:52:34 AM

Well..The card is now up and sort of running, but it seems its vista that doesnt actually like it though!
Windows Aero doesnt run at all, and my windows experience scores have crashed to 1.0 for gaming graphics and 1.9 for graphics, and when looking up solutions, I used Microsoft's Fix it program which is saying update the drivers for it as they arent Windows Display Driver Model (WDDM) compliant.
I have the latest drivers from AMD for the card (though only WinXP or Win7 options, not Vista?), and none of them on there are WDDM compliant :/  Ive tried the windows 7 ones so far.
Ive tried Catalyst 13.10 and 13.11 beta 9.2, but gpu-z says its still 13.9.



Also to note, Catalyst control center still will not run, and the AMD driver autodetect cannot find anything!
m
0
l
November 27, 2013 9:37:39 AM

Sorted it from another forum..
Had to fool the latest drivers into believing it was running on Windows 7 by editing the inf file. Now ive done it, card is working fine.
m
0
l
December 31, 2013 7:22:06 PM

what forum and what did you find as far as tricking the bios?
what did you have to do? I have the same problem.
m
0
l
January 1, 2014 2:47:03 PM

fyneyoungstunna said:
what forum and what did you find as far as tricking the bios?
what did you have to do? I have the same problem.


Err cant remember what post it was in, but pretty sure it was AMD's own forums
http://forums.amd.com/game/categories.cfm?catid=440

Even the thread title I found it in didnt look like it would have held the solution. I should have saved it for future use as I dont want to update drivers again as im likely to have the same problem I started off with lol
m
0
l
!