Sign in with
Sign up | Sign in
Your question
Solved

Hard drive not recognized until after using a partition software. (No operating system found.)

Last response: in Storage
Share
November 26, 2013 11:08:43 AM

Brief PC Specs:
Intel Duo Core 3.0Ghz
6gb DDR2 RAM
64b Windows 7 Ultimate
Nvidia Gtx9800+ 2Gb DDR2
Toshiba 1tb internal 3.5" HDD

Basically what happened was my old hard drive died (it was progressively getting worse, and eventually just stopped writing information). I used the dead hard drive for a few years before it died, in the same slot and the same SATA cable. I recently purchased a new replacement drive, a Toshiba 1tb Internal. When I first tried to install Windows 7 on this drive windows recognized that there is a drive there but it was unable to determine size and available space (and my bios did the exact same, (Sata0 - 0.0 MB). My previous hard drive in this slot would also show the brand and serial number in the Bios line for Sata0. In order to get my pc to acknowledge the size and space of this new hard drive I needed to use a disk partition software (I use EaseUS). I did not have to partition the disk or anything, all I needed the software to do was to boot from the CD and open the software. It then runs a scan for disk drives on the computer. As soon as EaseUS establishes that there is a drive there with 1000gb of space, I can close the software, remove the disc and boot normally.

Fast forward to where I am at now. There is Windows 7 Ultimate 64bit installed on this drive, amongst other games and drivers. The Pc runs fine, restarts fine, etc, but when I turn the computer off, and then turn it back on it doesn't boot from the hard drive and pops the error "No operating system found." and asks for a boot CD/Dvd. If I throw in EaseUS, let it scan for the disk, close the program, it will boot off the hard drive with no issues.

Ive tried different power supply connections, Ive tried different SATA cables, and different SATA ports on the mobo. I only have one desktop pc in my house so at this time Im unable to try the drive in another computer.

I can use this computer routinely with no issues, its just super inconvenient to jump through hoops on every startup.

At this point Im open to all serious suggestions, and any help is appreciated.
November 26, 2013 1:05:56 PM

what kind of motherboard are you using? make and model?
m
0
l

Best solution

November 26, 2013 1:19:04 PM

Have you gone into the bios and given the 1TB HDD the highest boot priority?
How many hard drives do you have?

I was having a similar problem. Hard drive and windows worked fine. Restarts fine. But when you actually shut down the computer and at some later point in time turn it back only to find the error message.

If that doesn't work then try pressing whatever key (for me it's "F12") gets you into the
boot menu and from there select the hard drive from the list.
Share
Related resources
November 26, 2013 1:23:53 PM

if your bios has Fast Boot enabled try to disable it and see if the system has enough time to spin up the drive.
m
0
l
November 26, 2013 1:43:35 PM

Emerald said:
what kind of motherboard are you using? make and model?


Its an Intel Q35 Motherboard.
And It doesnt have fast boot but it has the option for delayed POST to give the hard drive time to spin up.. I tried this with different time settings, 3, 6 ,9s, etc. and it made no change.

Cannabishead, Im only using this one HDD at the moment, though I have 2, the other is out while Im troubleshooting this. Ive tried booting with the HDD in every order of the boot sequence, all react the same, including when the HDD is top priority.

I havent been able to get into an alternate boot menu at all while all this is happening. It blinks the Lenovo start page with the option to go into bios, and immediately goes to the screen stating No operating system found.

Ive been playing with it practically all day and if it makes any difference, there was a sequence of about 4 startup attempts where my pc would say "Bootmgr is Missing. Press Ctrl+alt+del to restart pc." I remedied this with the windows disc and running startup repair. Hasnt done it again since, but BIOS still doesnt recognize my hdd until I enlighten it with EaseUS.

Thanks for your time, by the way.
m
0
l
November 26, 2013 1:55:43 PM

have you tried disabling the IDE connector in the BIOS?
m
0
l
November 26, 2013 1:57:23 PM

does a newer BIOS firmware exists?
m
0
l
November 26, 2013 2:01:39 PM

Emerald said:
does a newer BIOS firmware exists?


I am actually looking for newer bios firmware at the moment. And no I havent disabled the IDE connector. Ill try that if I cant find a newer bios.

Edit: Updated the BIOS with the only update available on the Lenovo website, and no change at all.

Checked in my BIOS settings and there doesnt appear to be an option to disable IDE connector, at least not an option that I noticed.
m
0
l
November 26, 2013 3:38:59 PM

Check which mode the sata port is in then clear/reset the bios. Then go back in and make sure the sata port is set the same way as before and if the drie is now being recognized.
m
0
l
November 26, 2013 6:07:33 PM

Just as an update, I didnt adjust the sleep settings on the pc after installing windows for the first time, with the default hard disk shut off at 20 minutes. After it went to sleep and I tried to wake it back up it seemed to have the same issue. So it appears that the hard disk is not spinning up until I use EaseUS to recognize it.

Obviously my power supply can handle the HDD, as it runs fine once I get it going. Also its obvious that my SATA cables and ports are fine, based on the same information. So whats happening appears to be that my HDD doesn't turn on from my regular boot sequence. Any suggestions as to why?
m
0
l
!