Sign in with
Sign up | Sign in
Your question
Solved

lag problem (big fps drop) help!?!? no solved yet

Tags:
  • Battlefield
  • Lag
  • PC gaming
  • Kingston
  • Games
  • FPS
  • Graphics
  • Asus
  • Graphics Cards
Last response: in Graphics & Displays
Share
November 28, 2013 8:33:24 AM

So for some reason i have really big lag and fps drop. when play tf2 normally 299fps at the menu now 50. at game 120 now 25. why is this happening? My friend said that its driver bug or something like that. and this is in any game not tf2 only

Pc specs
ASUS GeForce GTX 660 OC DCII 2GB GDDR5
amd fx-8320
ASUS M5A97 R2.0 AM3
XFX 450W PRO Core Edition V2 Full Wired 80+ BRONZE
KINGSTON HYPERX 8GB 1600MHZ DDR3 (2x4GB)
win 7 64 bit

More about : lag problem big fps drop solved

November 28, 2013 8:35:19 AM

Drivers and bios up to date? You always start there
m
0
l
a b Ĉ ASUS
a c 85 U Graphics card
November 28, 2013 8:35:26 AM

Reinstall tf2 and makeshur ur running latest drivers
m
0
l
Related resources
November 28, 2013 8:38:18 AM

Rune Olsen said:
Drivers and bios up to date? You always start there


i try to update drivers. I will tell you if i still have same problems
m
0
l
a b Ĉ ASUS
a c 85 U Graphics card
November 28, 2013 11:06:03 AM

And reinstall tf2 I've had to do that before
m
0
l
November 29, 2013 5:49:06 AM

iceclock said:
And reinstall tf2 I've had to do that before


but i have same problem in another games too. but yesterday after posting this i tried to install diver and reeboot my computer. after many times it worked! . and now i have same problem again. i don't think that the problem is in the drivers. does it have something to do with bios?.
m
0
l
November 29, 2013 6:02:59 AM

Rune Olsen said:
Drivers and bios up to date? You always start there


i dont think that its about the drivers
m
0
l
a b Ĉ ASUS
a c 85 U Graphics card
November 29, 2013 12:22:39 PM

is ur bios up to date?

m
0
l
November 29, 2013 1:35:58 PM

What PSU do you have? You never mentioned that, there can be issues on system load as well. First of all upgrade your bios and load optimized defaults so that can be eliminated. Then run aida at full load for an hour, see if it breaks down or not. Also load coretemp and post your temp readings to us while aida is running
m
0
l
a b Ĉ ASUS
a c 85 U Graphics card
November 29, 2013 1:45:25 PM

yes what kind of power supply do u own sir.

m
0
l
a b Ĉ ASUS
a c 85 U Graphics card
November 29, 2013 9:47:37 PM

Yes why double post?
m
0
l
a b Ĉ ASUS
a c 502 U Graphics card
November 29, 2013 9:54:15 PM

Well did you do a clean reinstall of drivers? ideally uninstall the nvidia drivers, use driversweeper then do a clean reinstall of one of the newer drivers
m
0
l
a b Ĉ ASUS
a c 85 U Graphics card
November 29, 2013 10:11:33 PM

I believe he did
m
0
l
November 30, 2013 12:24:50 AM




rolandzhang3 said:
Well did you do a clean reinstall of drivers? ideally uninstall the nvidia drivers, use driversweeper then do a clean reinstall of one of the newer drivers


I will try that. i will give you more information in Sunday. about temperatures and memory usage


so this is correct tool?
m
0
l
a b Ĉ ASUS
a c 502 U Graphics card
November 30, 2013 12:33:13 AM

Yep Driversweeper in safe mode after uninstalling the Nvidia Drivers, tick the clean installation option when you're installing the Nvidia drivers

Fiddling with BIOS should be your last resort
m
0
l
November 30, 2013 12:45:34 AM

rolandzhang3 said:
Yep Driversweeper in safe mode after uninstalling the Nvidia Drivers, tick the clean installation option when you're installing the Nvidia drivers

Fiddling with BIOS should be your last resort


sorry my bad English but did i understand you correctly

So i run pc in safe mode. then i uninstall Nvidia drivers with that tool.
is it good if get newest drivers to memory stick and install them form there?
m
0
l
a b Ĉ ASUS
a c 502 U Graphics card
November 30, 2013 12:50:11 AM

Uninstall Nvidia drivers from control panel and/or with Ccleaner

Boot into safe mode and run driversweeper (the video talks about AMD but Nvidia follows a similar process)

http://www.youtube.com/watch?v=DXs3DHdbTUg

Then download the latest driver (or which ever one you prefer) from the Nvidia website and do a "clean" installation of the driver
m
0
l
November 30, 2013 3:02:41 AM

Do a windows reinstall mate if this is not resolved yet. Might save you heaps of time
m
0
l
a b Ĉ ASUS
a c 502 U Graphics card
November 30, 2013 3:06:08 AM

That would, reinstalling everything and getting back up to snuff should take around 2-3 hours at most, it would be your last resort
m
0
l
November 30, 2013 5:38:40 AM

Rune Olsen said:
Do a windows reinstall mate if this is not resolved yet. Might save you heaps of time


rolandzhang3 said:
That would, reinstalling everything and getting back up to snuff should take around 2-3 hours at most, it would be your last resort


so is this correct drivers for my ASUS GeForce GTX 660 OC DCII 2GB GDDR5

https://www.asus.com/Graphics_Cards/GTX660DC2O2GD5/#sup...
do i download all?
m
0
l
a b Ĉ ASUS
a c 502 U Graphics card
November 30, 2013 5:40:20 AM

From here, don't fiddle with the video card's BIOS or frankly all the other stuff that's on Asus' site for now

Just download from Nvidia directly

http://www.nvidia.com/Download/index.aspx
m
0
l
a b Ĉ ASUS
a c 85 U Graphics card
November 30, 2013 11:48:23 AM

Yes download as Roland said if everything fails reinstall windows
m
0
l
December 1, 2013 7:09:58 AM

rolandzhang3 said:
From here, don't fiddle with the video card's BIOS or frankly all the other stuff that's on Asus' site for now

Just download from Nvidia directly

http://www.nvidia.com/Download/index.aspx








so what do you think i just re installed drivers
m
0
l
December 1, 2013 7:15:06 AM

iceclock said:
Yes download as Roland said if everything fails reinstall windows


look at the screenshots what i posted
m
0
l
a b Ĉ ASUS
a c 85 U Graphics card
December 1, 2013 9:22:36 AM

looks good.

m
0
l
December 1, 2013 9:55:03 AM

iceclock said:
looks good.



Looks good? but my GPU usage is always 98% is that normal and game are still laggy
m
0
l
a b Ĉ ASUS
a c 85 U Graphics card
December 1, 2013 10:07:50 AM

temps look good. its also possible the card is having issues, if continues ur allowed to send it back for replacement. could be an option if nothing else works

m
0
l
December 1, 2013 11:13:50 AM

iceclock said:
temps look good. its also possible the card is having issues, if continues ur allowed to send it back for replacement. could be an option if nothing else works



OMG now i found what makes my computer laggy! i dont know why. but its internet connection! when i am connect to internet games are laggy. and when i disconect i get my good 200 fps back! so why is this hapening?
m
0
l
a b Ĉ ASUS
a c 85 U Graphics card
December 1, 2013 11:18:13 AM

i dunno check if ur internet is working good. u using a wifi connection? maybe signals weak. let me know

m
0
l

Best solution

a b Ĉ ASUS
a c 502 U Graphics card
December 1, 2013 2:49:05 PM

viljami323 said:
iceclock said:
temps look good. its also possible the card is having issues, if continues ur allowed to send it back for replacement. could be an option if nothing else works



OMG now i found what makes my computer laggy! i dont know why. but its internet connection! when i am connect to internet games are laggy. and when i disconect i get my good 200 fps back! so why is this hapening?


That's certainly odd, I'd probably set my modem to factory default and do the quick setup again

Either that or you may have a background program constantly connected to the net and operating whilst you're in games

A conflict between your modem and GPU? that's quite a rare sight, and glad that the card itself is good since it's at 99% usage
Share
December 2, 2013 4:51:41 AM

rolandzhang3 said:
viljami323 said:
iceclock said:
temps look good. its also possible the card is having issues, if continues ur allowed to send it back for replacement. could be an option if nothing else works



OMG now i found what makes my computer laggy! i dont know why. but its internet connection! when i am connect to internet games are laggy. and when i disconect i get my good 200 fps back! so why is this hapening?


That's certainly odd, I'd probably set my modem to factory default and do the quick setup again

Either that or you may have a background program constantly connected to the net and operating whilst you're in games

A conflict between your modem and GPU? that's quite a rare sight, and glad that the card itself is good since it's at 99% usage

and now it works again! what i did i closed program from task manager called dlhost.exe and now it works perferfly no problems at all!
m
0
l
December 2, 2013 4:51:41 AM

rolandzhang3 said:
viljami323 said:
iceclock said:
temps look good. its also possible the card is having issues, if continues ur allowed to send it back for replacement. could be an option if nothing else works



OMG now i found what makes my computer laggy! i dont know why. but its internet connection! when i am connect to internet games are laggy. and when i disconect i get my good 200 fps back! so why is this hapening?


That's certainly odd, I'd probably set my modem to factory default and do the quick setup again

Either that or you may have a background program constantly connected to the net and operating whilst you're in games

A conflict between your modem and GPU? that's quite a rare sight, and glad that the card itself is good since it's at 99% usage

and now it works again! what i did i closed program from task manager called dlhost.exe and now it works perferfly no problems at all! and GPU usage is now 1% only
m
0
l
a b Ĉ ASUS
a c 502 U Graphics card
December 2, 2013 5:11:01 AM

Good to know haha
m
0
l
a b Ĉ ASUS
a c 85 U Graphics card
December 2, 2013 8:09:49 AM

Excellent
m
0
l
!