Sign-in / Sign-up
Your question
Solved

new built pc won't turn on! plz HELP

Tags:
  • Asus
  • Build
  • Systems
Last response: in Systems
November 30, 2013 2:33:21 AM

so guys i have just build myself a new pc and assembled by a friend experienced in this domain, but when i tried to start my computer, nothing happened! i won't start :(  but i see a light glowing on and off in my motherboard and when i press it too, nothing happens :( 
I am at lost guys, and if someone can help me, it can only be you, Thanks for everything!

My Build:
CPU: I7 4770K
CM: ASUS Z87 PRO
RAM: 16Go CORSAIR DOMINATOR PLATINIUM 1866MHZ
GPU: EVGA ACX gtx 780
Case: corsair Carbide 500r
SSD: Corsair Force GS 360Gb
PSU: Seasonic 850W gold+

More about : built turn plz

a b Ĉ ASUS
November 30, 2013 2:36:19 AM

nothing looks wrong. i suspect a cable isn't plugged properly.
m
0
l
November 30, 2013 3:25:20 AM

You may want to try unplugging all usb devices and seeing if that allows your pc to start up. I frequently find that this helps.
m
0
l
Related resources
November 30, 2013 3:31:05 AM

i believe they are correctly plugged but just to be sure, here are some pics:
Red Light

No Red Light


m
0
l
a b Ĉ ASUS
November 30, 2013 3:36:38 AM

What exactly happens when you hit the power button? Anything at all? Fans spin up? Are you getting a Qcode on the motherboard? Please give details about what the motherboard lights look like before/after hitting power on.
m
0
l
November 30, 2013 3:37:54 AM

no my friend, nothing! i tried unpluging and plugging the cables, but no luck :( 
after i plug the power cable (of the psu) a red light start glowing on my motherboard, but nothing happen when i try to start the pc :( 
m
0
l

Best solution

a b Ĉ ASUS
November 30, 2013 3:41:01 AM

I recommend going through this post, slowly, and in detail. Some steps may seem too obvious, don't skip them. This will help find out whether or not you need to RMA anything.
"No POST", "system won't boot", and "no video output" troubleshooting checklist
"No POST", "system won't boot", and "no video output" troubleshooting checklist This checklist is a compilation of troubleshooting ideas from many forum members. It's very important to actually perform every step in the checklist if you want to... See full content
Share
November 30, 2013 3:49:15 AM

ok thanks dear friend, i will! =)
m
0
l
November 30, 2013 6:34:34 AM

i have tested the PSU with the paper clip methode and its working just fine! after that i removed my MOB from the case and then tested it with CPU and Ram on it ( and i tried all kind of rams) but it still wont start and i only get the flashing red light!
m
0
l
December 1, 2013 2:59:52 AM

Guys!! Plz help!
m
0
l
a b Ĉ ASUS
December 1, 2013 3:09:14 AM

it's trial and error, take each component out of the equation one at a time till you find the one causing the issue. doesn't matter in which order.
m
0
l
a b Ĉ ASUS
December 1, 2013 3:14:40 AM

If you have gone through the list I posted above, and didn't find the problem, it is probably a hardware failure. It is hard to say which one it is, but I think I'd start with sending the motherboard back for a new one. It's strange that it isn't giving you a Qcode.
m
0
l
December 1, 2013 10:13:31 AM

yeah i thought as much, i took each component aside, and i was left between CPU and Mob? cuz even with just these two, the Mob doesnt even power up, so how can i be sure that its a mob and not CPU?! :( 
thanks for the replies guys
m
0
l
a b Ĉ ASUS
December 1, 2013 11:34:29 AM

you plug the cpu in a mobo that you know works. or plug a cpu to you know works on the mobo.
m
0
l
December 1, 2013 11:38:06 AM

the problem is that this is my first build ever, and have no other Mob nor CPU !
m
0
l
December 1, 2013 4:11:21 PM

Bad news guys, i just checked my Mob CPU pins and 2 of them are bent, does having that matches the problem i had? And how can i fix them? If there is any methode plz share it with me!
Thanks for the helps my friends
m
0
l
a b Ĉ ASUS
December 1, 2013 11:10:45 PM

yep. it's consistent with the simptomps. use a small needle to try and bend them back into place. put it down next to other straight pins and slowly lift it back while leaning it against the tilted pins. and be very careful when you insert it back. you should feel when it gets in right. make sure to check that arrow symbol for socket placement. and lift that handle on the side of the socket.

i fixed one like that one time. if they are not broken you can get it to work.
m
0
l
December 1, 2013 11:25:05 PM

wow i just ordered my own parts.. good luck man!
m
0
l
December 2, 2013 5:08:05 AM

Ok guys thanks! A bunch, im gonna update my post with every bit of news, hoppefuly i do it right this time
m
0
l
December 2, 2013 11:29:09 AM

Well, i couldnt ger the pins back :(  , gonna have to but a new mob..... Shiiit :( 
m
0
l
a b Ĉ ASUS
December 2, 2013 11:34:00 AM

maybe it got dmged during transport, you can try to rma it.
m
0
l