New R9 270X not working?!

Hello there I bought a new GPU - http://www.overclockers.co.uk/showproduct.php?prodid=GX-093-HS R9 270X card. The problem is the card seem not to be working, the fan is not spinning after power up. Yes, I plugged the cable from PSU to GPU.
I am very affraid the card may be faulty? I hope not though, but what may be the problem then? Compatibility?

MB: ASUS M4A785T-M
PSU: Fortron FSP500-60GHN 500W 80 Plus

Thank you hope you can help.
5 answers Last reply
More about 270x working
  1. Attempt to upgrade your bios. It's likely to be the case.

    Also make sure your ram isn't faulty, check by usin your integrated GPU and 1 ram stick, change the dimm slot if it doesn't work with one slot.

    However, I'm sure a bios update should do the trick.

    Check your mobo manual on how to flash your bios.

    Good luck!
  2. The thing is I was updating my bios like 2-3 weeks ago so it should be updated. I was buying new 4gb ram stick to get 8gb total and the ram wasnt working for me so i did the update of bios, it solved the ram problem but now the gpu is not running. aaargh. any other ideas?
  3. Okay progress i managed to plug the card more properly i guess, somehow the fan is now spinning but the problem now is that starts for 3-5 seconds and then suddenly stops. i believe all the cables are plugged properly. any ideas?
  4. More properly? There's only one way to connect the GPU. :)

    Ensure the GPU is seated properly an the 6/8pin is connected to the GPU and psu
  5. perd0 said:
    Okay progress i managed to plug the card more properly i guess, somehow the fan is now spinning but the problem now is that starts for 3-5 seconds and then suddenly stops. i believe all the cables are plugged properly. any ideas?


    I have the same problem with a MSI R9 270x.
Ask a new question

Read More

GPUs Power Up Graphics