Sign in with
Sign up | Sign in
Your question
Solved

New games lag after installing new graphics card

Last response: in Graphics & Displays
Share
December 2, 2013 12:06:14 PM

Hello, today I installed a new graphics card
a b U Graphics card
December 2, 2013 12:15:24 PM

Your going to have to be alot more specific then just i installed a new graphics. What graphics card is it? what sort of lag are you getting? what resolution/settings are you playing at and what games? Also whats the rest of your computers specs? Then we can help :) 
m
0
l
a b 4 Gaming
a b U Graphics card
December 2, 2013 12:17:34 PM

Yes. What's the framerate you were and now are getting? Is your PSU delivering sufficient power? Is it a generic or a branded PSU?
m
0
l
Related resources
a b 4 Gaming
a b U Graphics card
December 2, 2013 12:34:55 PM

Point 1: why did you post 2 threads 15 minutes off?
Point 2: what is your PSU?
m
0
l
December 2, 2013 12:41:13 PM

Sorry new here, I accidentally hit the publish button when I wasn't done. MY PSU is 550 so I don't think it's the PSU
m
0
l
a b 4 Gaming
a b U Graphics card
December 2, 2013 12:46:35 PM

550 doesn't say the story.
A generic power supply designed to fool unsuspecting buyers by using cheap components can deliver low enough current to lag even low-end graphics cards.
Post more details. Open your case and take a photo of your PSU sticker if you're not sure.
m
0
l
a b 4 Gaming
a b U Graphics card
December 2, 2013 12:58:34 PM

When did you buy your PSU? The site you posted says that the psu is end of life.
If your PSU is getting old, it starts to lose power.
If your PSU is old enough, consider getting a new one.
m
0
l
a b U Graphics card
December 2, 2013 1:06:44 PM

Whats the video card that you bought? and whats the rest of your system specs?
m
0
l
December 2, 2013 1:08:18 PM

but my previous graphics card used to work fine with the PSU,
m
0
l
December 2, 2013 1:15:05 PM

windows 7 64-bit OS
GIGABYTE GeForce GTX 650 Ti
GA-G41M-Combo motherboard
core 2 quad q9550 2.83GHz
8 gb of ram
m
0
l
a b U Graphics card
December 2, 2013 1:19:44 PM

cst1992 said:
Inertia01 said:
Whats the video card that you bought? and whats the rest of your system specs?


Quoting for reference
Quote:
Hello, so today I bought a new graphics card GTX 650 OC ti 2GB and it lags on some new games, I had a gts 450 before but it didn't lag!!! plz help!! what could be the problem?

here's my specs
windows 7 64-bit OS
GIGABYTE GeForce GTX 650 Ti
GA-G41M-Combo motherboard
core 2 quad q9550 2.83GHz
8 gb of ram


His computer specs haven't come up for me i cant see them but i just went to his link why is there two threads for this? Anyway looking at your cpu its a low clock speed and an old cpu which is bottlenecking your 650ti and would explain the lag/frame drops in any new games you play as lot of games are cpu heavy but what resolution are you playing at and what games are you playing?

m
0
l
December 2, 2013 1:43:33 PM

Not all new games lag, skyrim & call of duty black ops 2 & mafia 2 don't lag but a little bit slow, I'm playing at 1360x768 res, GTA IV & call of duty black ops lag a lot, I used to play those games smoothly with my previous graphics card gts 450 so I think my new graphics card is causing the lag
m
0
l
a b 4 Gaming
a b U Graphics card
December 2, 2013 9:24:44 PM

Inertia01 said:

His computer specs haven't come up for me i cant see them but i just went to his link why is there two threads for this?


You don't go through the whole thread, do you?
m
0
l
a b U Graphics card
December 3, 2013 4:12:30 AM

cst1992 said:
Inertia01 said:

His computer specs haven't come up for me i cant see them but i just went to his link why is there two threads for this?


You don't go through the whole thread, do you?


Yes i do but as i said messages were not showing up at all for me

m
0
l

Best solution

a c 223 4 Gaming
a c 487 U Graphics card
December 3, 2013 4:16:30 AM

Did you clean out your older drivers before installing your new card? that may be the conflict

Generally people prefer to uninstall their graphics drivers, use driversweeper to clean the rest out, then install the latest driver directly from AMD/Nvidia
Share
!