Sign in with
Sign up | Sign in
Your question
Solved

Crossfirex wont show in Amd Catalyst

Last response: in Graphics & Displays
Share
December 5, 2013 2:55:16 PM

I just got another 7870 to crossfire with and when I put the card in and connect the crossfire bridge it only shows 1 card still. I cant find crossfirex anywhere on the catalyst help please
December 5, 2013 3:05:12 PM

CrossfireX should be under "Gaming" or "Performance" (I can't remember which one right off the top of my head, and I'm not at my desktop computer to look).

Does the second card show up in Device Manager or with software like GPU-Z?

Casey
m
0
l
December 5, 2013 3:07:52 PM

No it doesn't show but I tried both of the cards by them selves and they work fine and the only option I see under gaming is 3d Application settings and under performance is AMD Overdrive
m
0
l
Related resources
December 5, 2013 3:11:53 PM

What motherboard and Catalyst version are you using?

Casey
m
0
l
December 5, 2013 3:14:35 PM

Msi Z87 G45 Motherboard and catalyst version 13.9
m
0
l
December 5, 2013 3:14:36 PM

Msi Z87 G45 Motherboard and catalyst version 13.9
m
0
l
December 5, 2013 3:40:11 PM

Which PCI Express slots do you have the cards installed in? The manual for your board says to install the cards in PCI_E2 and PCI_E5.

Casey
m
0
l
December 5, 2013 4:04:22 PM

They are installed on those :c I have a sapphire Ghz edition 7870 and a HIS ghz edition 7870
m
0
l
December 5, 2013 5:24:06 PM

Since they are of the same GPU family, they should work just fine in CrossfireX mode. Different card manufacturers shouldn't matter. What power supply are you using?

Sorry, I'm running out of ideas here. Assuming you have enough power available, your computer should be running in CrossfireX mode. In fact, when I set up my 7770s for CrossfireX, Catalyst Control Center popped up asking if I wanted to enable CrossfireX mode. I just can't figure out why your setup isn't doing the same.

Casey
m
0
l
December 5, 2013 6:30:43 PM

Well I seem to found the problem... it appears when I have my tower up the cards bend down from the pci slots and doesn't show the second card I tried screwing in the card to the case but it still didn't show up on the catalyst but when I have my computer laid down it shows the card...
m
0
l

Best solution

December 5, 2013 7:47:39 PM

Sounds like the second card may not be seated all the way. I'd try pushing it into the slot a bit harder. Not enough to bend the motherboard, though.

Casey
Share
December 6, 2013 8:13:48 PM

Well Your right it was not seated all the way in by like 1 millimeter but to get it in all the way I had to bend the bracket with pliers that screws into the case to get it to go in all the way. the card is working good now thanks for the help! and good thing I got a 2 year accidental damage warranty haha
m
0
l
December 6, 2013 8:54:07 PM

Glad to hear your problem is fixed.

Casey
m
0
l
!