Sign in with
Sign up | Sign in
Your question

Battlefield 4 Start-Up Crash (PC)

Last response: in Video Games
Share
December 7, 2013 6:21:59 AM

Hello Everyone,

Please not before reading, I have an nVidia GT 640 that isn't listed and I have posted in EA answers but have received no response.

Last night I installed Battlefield 4: Deluxe Edition for PC.
I went to play it in the morning and it launched fine. I use Google Chrome for my browser. I installed the web plugin and joined a server.
I joined the server using x64 Battlefield 4, and upon start-up it crashing, saying, "Battlefield 4 is not responding."
After this I tried many fixes including all of these:

Starting in x86 Battlefield 4. When it enters the map looks weird with textures flying everywhere and I can't see my gun. I can only see my mini-map. (Tried on Campaign, Multiplayer and Test Range. None of them worked)

I reinstalled PunkBuster. Didn't do anything.

Fixed the download on Origin. Didn't do anything.

Re-installed the web plugin. Didn't do anything.

Updated my graphics card. Didn't do anything.

Restarted computer. Didn't do anything.

I really don't know what is happening and any response would be of a huge help.
Here is my spec:

------------------ System Information ------------------
Time of this report: 12/3/2013, 18:14:09
Machine name: ALEXANDER-PC
Operating System: Windows 8 64-bit (6.2, Build 9200) (9200.win8_gdr.130531-1504)
Language: English (Regional Setting: English) System Manufacturer: Dell Inc.
System Model: XPS One 2710
BIOS: A09
Processor: Intel(R) Core(TM) i7-3770S CPU @ 3.10GHz (8 CPUs), ~3.1GHz
Memory: 8192MB RAM Available OS Memory: 8078MB RAM
Page File: 3645MB used, 5905MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.02.9200.16384 64bit Unicode

------------ DxDiag Notes ------------
Display Tab 1: No problems found.
Sound Tab 1: No problems found.
Sound Tab 2: No problems found.
Sound Tab 3: No problems found.
Input Tab: No problems found.

-------------------- DirectX Debug Levels --------------------
Direct3D: 0/4 (retail)
DirectDraw: 0/4 (retail)
DirectInput: 0/5 (retail)
DirectMusic: 0/5 (retail)
DirectPlay: 0/9 (retail)
DirectSound: 0/5 (retail)
DirectShow: 0/6 (retail)

--------------- Display Devices ---------------
Card name: Intel(R) HD Graphics 4000
Manufacturer: Intel Corporation
Chip type: Intel(R) HD Graphics Family
DAC type: Internal
Device Type: Full Device
Device Key: Enum\PCI\VEN_8086&DEV_0162&SUBSYS_054B1028&REV_09
Display Memory: 1664 MB
Dedicated Memory: 32 MB
Shared Memory: 1632 MB
Current Mode: 2560 x 1440 (32 bit) (59Hz)
Monitor Name: Generic PnP Monitor
Monitor Model: XPS One 2710
Monitor Id: @@@0000
Native Mode: 2560 x 1440(p) (59.951Hz)

Thank you in advance for all your help.
Alexander
December 8, 2013 9:37:12 PM

My friend ad a similar problem he needed to disactivate the plugin then lauch the game en redownload it then he could play...try running the game in administrator or in compabilitie mode ?
m
0
l
!