Solved

hello i bought a 7750 saphire....upgraded from an ati 3870?

the problem is i upgraded from an ati 3870 and on my monitor the 1600 x 900 looked really cripsy however on this new one it is abit blurry...
also when i change the screen resoltuion in the settings it says generic non pnp montior even thought i installed driversf rom cd......

in addition i have connected a dvi connector does this affect it? as my vga cable does not go in the back of the graphic card without the connector?

i just want to know how to get 1600 x 900 on the new graphics card
10 answers Last reply Best Answer
More about bought 7750 saphire upgraded ati 3870
  1. Download the drivers from amd's website
  2. i have done it is still nto working?
  3. in the screen resoltuion it says generic non pnp monitor? in my last one im sure it sais ati hd 3870...it should be says hd 7750 in the place where it says non generic montior....

    in device manager shall i uninstall the non generic pnp monior?
  4. Dude why are you bumping after just 7 minutes since the last response?
    Can you list what it shows under the display adapters segment in device manager?
  5. Best answer
    Just uninstall all Graphics adapters in "Device Manager". Then Reboot. After that download this tool :http://support.amd.com/en-us/download/auto-detect-tool . After the installation is complete , reboot! The DVI to VGA connector is something normal. I also use it and It never caused a problem.
  6. No bumping!
  7. smeezekitty said:
    Dude why are you bumping after just 7 minutes since the last response?
    Can you list what it shows under the display adapters segment in device manager?


    it shows my graphics card hd 7750 when i go onto it it says device working fine...m mate goes your montior is too old as its only vga but i said i do not think it is that.....
  8. smeezekitty said:
    Dude why are you bumping after just 7 minutes since the last response?
    Can you list what it shows under the display adapters segment in device manager?


    under dispay adapters it just says my new graphics card thats it.........my mate goes my monitor is too old as it only supports vga but i dnt think that is the problem
  9. hunter86_bg said:
    Just uninstall all Graphics adapters in "Device Manager". Then Reboot. After that download this tool :http://support.amd.com/en-us/download/auto-detect-tool . After the installation is complete , reboot! The DVI to VGA connector is something normal. I also use it and It never caused a problem.


    i know i have unistalled all old drivers and installd new drivers from the website...when i choose 1600 x 900 the screen is out of focus....dont know why

    by the way the port behindmy montior is only vga and the ports behind my graphi card is dvi...so im using the connector behind my graphics card...from vga to dvi
  10. someone said go on device manager and unistall the generic pnp monior from there there disconect cable from graphic card and connect it after 5 seconds then restard and it shud b ok..but idnt wanna unistall generi pnp monitor what if it goes blank
Ask a new question

Read More

ATI Monitors ABIT Graphics