Solved

Year Old Custom PC Turns On and Off Repeatedly

I've had a custom built PC since January of this year, my first one. No major problems since then until the other day, when I came home to find my computer had turned off on its own (I generally leave it running all the time). No sign of a power outage so I tried to turn it on and that lasts about 5-6 seconds or so before it shuts itself off. Nothing comes up on the display either. And unless I unplug it, after a few seconds of being off, it will try to turn on again, then repeat the process.

I've pretty much tried everything I could the last few days. I went through the sticky post about what to try and do before posting about this issue. Tried a new power supply, no luck. Tried a new motherboard (it's a good thing I got the replacement plan on everything when I bought this!), same result. Tried unplugging one thing at a time, across the board, and still always the same result. Tried using one stick of RAM in each slot, still the same result.

The only thing I have yet to try is replacing the CPU. Now luckily I have the replacement plan on that also, and they have a good deal of i7-3770k processors in stock. That's pretty much my last move, and hopefully it does the trick. Does this sound like a possibility to anyone? That the CPU is the problem? And does anyone have any other ideas as to what might be the cause that I may not have tried yet?
4 answers Last reply Best Answer
More about year custom turns repeatedly
  1. Have you tried booting into BIOS? You may be able to go back to your last successful restore point.
  2. Best answer
    Turn off PSU switch on the back of the PC, Turn on PC which will just run for a few sec,s. Turn PSU switch on again and boot up. Your Bios is stuck in a loop from the power shutdown and although you have tried another PSU you haven,t drained the residual power from the motherboard. Happens to 1 of my PC,s every time there is a power outage, it loops. There is just enough power still in the mobo to prevent it from resetting, simple bit of power causing so much problems.
  3. CTurbo said:
    Have you tried booting into BIOS? You may be able to go back to your last successful restore point.


    Unfortunately, I never get the opportunity. Never gets to that point, dies out before I can get that option, and the display doesn't come up at all either.
  4. makoau58 said:
    Turn off PSU switch on the back of the PC, Turn on PC which will just run for a few sec,s. Turn PSU switch on again and boot up. Your Bios is stuck in a loop from the power shutdown and although you have tried another PSU you haven,t drained the residual power from the motherboard. Happens to 1 of my PC,s every time there is a power outage, it loops. There is just enough power still in the mobo to prevent it from resetting, simple bit of power causing so much problems.



    I've done this many times, to no avail. Also, I'm on motherboard #2, same issue as the first one before I replaced it.
Ask a new question

Read More

Power Outage CPUs