Sign in with
Sign up | Sign in
Your question
Solved

Samsung Magician reports that my system isn't in AHCI mode

Last response: in Storage
Share
December 9, 2013 12:26:24 PM

I have a Samsung Pro SSD in an HP Z210 Workstation. Samsung Magician reports that my system is not in AHCI mode, though I have RAID+AHCI selected in the BIOS. HP would offer me no help on this, because the Samsung SSD wasn't original equipment that shipped with the machine. Does anyone know why Samsung Magician thinks my system isn't in AHCI mode?
a b G Storage
December 9, 2013 12:28:46 PM

Im not a SSD expert but not sure your SSD likes the Raid.
m
0
l
Related resources
December 9, 2013 12:48:09 PM

laviniuc said:
i dont think the raid+ahci is the same thing... try the regedit fix for the ahci and switch in bios to ahci mode
http://www.sevenforums.com/hardware-devices/17876-enabl...
http://forums.pcper.com/showthread.php?444831-HOWTO-ena...


The Z210 Workstation doesn't have an AHCI mode in the BIOS - just IDE or RAID+AHCI. But I tried the regedit fix anyway. It made no difference, Samsung Magician still reports that AHCI Mode is Deactivated, and is "Unable to detect SATA interface details."

I read some other threads here on this topic (there are quite a few) - one said to run AS SSD Benchmark so I did. It lists the drive as "C: Samsung SSD 840 PRO Seri SCSI Disk", not as AHCI. So I guess the HP Z210 Workstation's BIOS is reporting a SCSI rather than an SATA AHCI interface? Why is that?
m
0
l
a b G Storage
a b Ô Samsung
December 9, 2013 2:27:00 PM

timbck2 said:
laviniuc said:
i dont think the raid+ahci is the same thing... try the regedit fix for the ahci and switch in bios to ahci mode
http://www.sevenforums.com/hardware-devices/17876-enabl...
http://forums.pcper.com/showthread.php?444831-HOWTO-ena...


The Z210 Workstation doesn't have an AHCI mode in the BIOS - just IDE or RAID+AHCI. But I tried the regedit fix anyway. It made no difference, Samsung Magician still reports that AHCI Mode is Deactivated, and is "Unable to detect SATA interface details."

I read some other threads here on this topic (there are quite a few) - one said to run AS SSD Benchmark so I did. It lists the drive as "C: Samsung SSD 840 PRO Seri SCSI Disk", not as AHCI. So I guess the HP Z210 Workstation's BIOS is reporting a SCSI rather than an SATA AHCI interface? Why is that?


MAgician doesn't function properly or at all when RAID is enabled.
m
0
l
December 9, 2013 2:38:19 PM

Palorim12 said:

MAgician doesn't function properly or at all when RAID is enabled.


But I don't actually have the drive in a RAID configuration - it is a standalone drive.
m
0
l
a c 523 G Storage
a b Ô Samsung
December 9, 2013 2:59:56 PM

Install Intel's latest AHCI drivers and see if that will allow Samsung Magician to recognize your SSD in AHCI mode. https://downloadcenter.intel.com/Detail_Desc.aspx?Dwnld...

Also, I believe that Samsung just released version 4.3 of Magician. If you don't have that version then uninstall the version you currently have, reboot your system, then install version 4.3. http://www.samsung.com/global/business/semiconductor/sa...
m
0
l
December 10, 2013 11:19:24 AM

Dereck47 said:
Install Intel's latest AHCI drivers and see if that will allow Samsung Magician to recognize your SSD in AHCI mode. https://downloadcenter.intel.com/Detail_Desc.aspx?Dwnld...

Also, I believe that Samsung just released version 4.3 of Magician. If you don't have that version then uninstall the version you currently have, reboot your system, then install version 4.3. http://www.samsung.com/global/business/semiconductor/sa...


I already have the latest AHCI drivers and Samsung Magician 4.3.
m
0
l
a b G Storage
a b Ô Samsung
December 11, 2013 6:31:58 AM

timbck2 said:
Dereck47 said:
Install Intel's latest AHCI drivers and see if that will allow Samsung Magician to recognize your SSD in AHCI mode. https://downloadcenter.intel.com/Detail_Desc.aspx?Dwnld...

Also, I believe that Samsung just released version 4.3 of Magician. If you don't have that version then uninstall the version you currently have, reboot your system, then install version 4.3. http://www.samsung.com/global/business/semiconductor/sa...


I already have the latest AHCI drivers and Samsung Magician 4.3.


From the Samsung Magician 4.3 installation guide: "RAID on mode in SATA configuration is not supported by Samsung magician and DOS application."

There's also a chance your windows could be giving your drive A SCSI driver since RAID is enabled in the BIOS.
m
0
l

Best solution

January 2, 2014 1:54:04 AM

Please check your drive's speed.
The Magician indeed does not work correctly on this workstation. Due to the bios options you are given.
If the speed is up to par, and it gives you th SCSI driver you should be fine, even TRIM will work correctly.
Have the same setup;).
Share
!