Sign in with
Sign up | Sign in
Your question
Solved

Your experience with the new amd drivers and BF4 fps issues?

Last response: in Graphics & Displays
Share
December 9, 2013 6:17:03 PM

i have a radeon hd 7790, and for me, every single update after 13.11 beta v1 has crashed consistently. for those of you with amd cards, does this happen to you? i really wanted to upgrade because i think in one of the updates the performance of bf4 got boosted, but i cant the driver just keeps crashing. ok, now about bf4: does anyone else get microstuttering? its not really lag, just a split second of single digit framerate and then its ok. whats the deal here? anyone else get this or know a fix?
a c 171 À AMD
December 9, 2013 10:34:40 PM

don't use any beta driver..
use the fix and official..

My card still run at 13.9, and running with no single issue..
m
0
l
a b À AMD
December 9, 2013 11:06:35 PM

Has it been crashing in bf4 only?
m
0
l
Related resources
Anonymous
December 10, 2013 12:04:10 AM

My Asus hd 7790 dcu 2 Oc, also the same as yours, after 13.11 beta 1 driver theres something wrong that cant fix. So i have to use Beta 1, cause its better than 13.9 whql when i play TR 2013, No drop to 19 Fps when aiming the weapon. Later I will try to play BF4, to find out the problem.
m
0
l

Best solution

December 10, 2013 12:39:10 AM

I have a 7850 2 GB. For me it all depends on the server I'm playing on if I crash/freeze or not. The remaining issues in BF4 seems to be server related.

There's one server (was my favourite of course) that I can't play a full round on Siege of Shanghai without crashing and where the soundbugs are so bad on Golmud Railway that it's unplayable. All these issues are non-existing on other servers.

On the right server I get a smooth flawless gameplay with the 7850 2 GB on ultra with some minor tweakings.
Share
a b À AMD
December 10, 2013 2:10:11 AM

I gave up on my 7790 as it GSOD's and puts the monitor to sleep whilst simply browsing the internet!
m
0
l
December 10, 2013 4:20:20 PM

Mousemonkey said:
I gave up on my 7790 as it GSOD's and puts the monitor to sleep whilst simply browsing the internet!


thats what has been happening to me as well. i fixed it though downgrading to 13.11 beta v1. you shoudl try that
m
0
l
a b À AMD
December 10, 2013 4:26:29 PM

I tried that driver as well and still had GSOD's and the monitor randomly turning off.
m
0
l
December 13, 2013 3:46:45 PM

Mousemonkey said:
I tried that driver as well and still had GSOD's and the monitor randomly turning off.


huh that sucks. try using the last non beta driver
m
0
l
a b À AMD
December 13, 2013 3:51:22 PM

shiftyape said:
Mousemonkey said:
I tried that driver as well and still had GSOD's and the monitor randomly turning off.


huh that sucks. try using the last non beta driver


I got as far as the 13.11v1 beta then decided to go back to the 560Ti as then I don't have to deal with any issues at all because it just works.
m
0
l
December 13, 2013 3:57:53 PM

Mousemonkey said:
shiftyape said:
Mousemonkey said:
I tried that driver as well and still had GSOD's and the monitor randomly turning off.


huh that sucks. try using the last non beta driver


I got as far as the 13.11v1 beta then decided to go back to the 560Ti as then I don't have to deal with any issues at all because it just works.


well, as long as it worked out, right?
m
0
l
a b À AMD
December 13, 2013 4:05:54 PM

shiftyape said:
Mousemonkey said:
shiftyape said:
Mousemonkey said:
I tried that driver as well and still had GSOD's and the monitor randomly turning off.


huh that sucks. try using the last non beta driver


I got as far as the 13.11v1 beta then decided to go back to the 560Ti as then I don't have to deal with any issues at all because it just works.


well, as long as it worked out, right?


I still have the card and intend to try something with it in my next build, so roll on Broadwell! ;) 
m
0
l
December 13, 2013 4:10:30 PM

Mousemonkey said:
shiftyape said:
Mousemonkey said:
shiftyape said:
Mousemonkey said:
I tried that driver as well and still had GSOD's and the monitor randomly turning off.


huh that sucks. try using the last non beta driver


I got as far as the 13.11v1 beta then decided to go back to the 560Ti as then I don't have to deal with any issues at all because it just works.


well, as long as it worked out, right?


I still have the card and intend to try something with it in my next build, so roll on Broadwell! ;) 


good luck. im an amd guy myself
m
0
l
a b À AMD
December 13, 2013 4:38:19 PM

Been there, done that. I gave up on AMD CPU's after the 939 backstab.
m
0
l
!