Sign in with
Sign up | Sign in
Your question

Repair: Newly installed GPU, max fans running, black screen after windows loading

Last response: in Systems
Share
December 9, 2013 10:10:30 PM

I dont which section to post this but here it goes:

I came from a gtx 770 and downgraded from a gtx 680 4gb and installed it in my system. After that I noticed that the fans were on full speed.. which was odd. And then it went to boot to windows (obviously using the integrated driver and not the gpu), it then proceeded to install the gtx 680 after that I restarted the computer. After the loading screen, it couldnt boot into the windows OS, its just black screen and the fans are running at max speed so I just turned it off.

The next day I uninstalled all the drivers and also use driver sweeper, but to no avail.

I dont know what is wrong is it my power supply or my gpu? should i reformat my pc? i dont have any spare gpu and psu to use so i dont know what is the problem :/ 

i also tried changing the pcie slot, cleaning the pcie slot and also changing the bios to no avail


Specs:
3770k
sabertooth z77
vengeance LP 8gb 2x2
Noctua d14
GTX 680 4gb (Palit)
Corsair HX1000
500gb wd black
1tb seasonic
December 9, 2013 10:29:00 PM

Your PSu is good quality and ridiculous overkill for that GPU so I doubt this is the issue.
m
0
l
December 9, 2013 10:34:55 PM

tiny voices said:
Your PSu is good quality and ridiculous overkill for that GPU so I doubt this is the issue.


I would be going sli in the future
m
0
l
Related resources
December 9, 2013 10:37:42 PM

750w is all you need for SLI gtx680s. 1000w is pointless and you will use so little of it on a single card it will run inefficiently at such low wattage and actually use MORE power from the wall and waste it as heat than a lower wattage unit. But, I doubt it is the PSU.
m
0
l
December 9, 2013 10:43:56 PM

tiny voices said:
750w is all you need for SLI gtx680s. 1000w is pointless and you will use so little of it on a single card it will run inefficiently at such low wattage and actually use MORE power from the wall and waste it as heat than a lower wattage unit. But, I doubt it is the PSU.


i also doubt it is because when i had the gtx 770 it was working, but then i installed this gtx 680 and the fans were running max at the start and i couldnt login to windows once i installed the drivers :/ 
m
0
l
!