Solved

Can't set native resolution of monitor with R9 280x

Hello,i've recently tried fixing a problem which caused the screen to flicker when playing games with my Sapphire Toxic r9 280x GPU and Samsung SyncMaster 2243 monitor,but as i fooled around in AMD Catalyst Control Centre it changed my resolution and now i can't set anything above 1600x1200.My monitor is designed for 1680x1050 and my GPU surely can run it so i can't see the problem.I tried reinstalling GPU drivers then installing monitor drivers(first time i ever did and it ran before that in 1680) but nothing seems to work.I tried unplugging and plugging back monitor power cable.Windows shows my monitor as Generic Non-Pnp.
3 answers Last reply Best Answer
More about set native resolution monitor 280x
  1. Most of the time the monitor don't need drivers. Uninstall the monitor drivers. Try a different cable or plug the DVI cable to the other DVI port.
  2. Best answer
    1600x1200 is a 4:3 aspect ratio.
    Look for a drop down that allows you to choose 16:10 aspect ratio resolutions.
  3. I enabled GPU scalling which probably messed with the aspect ratios.Thanks for the quick and helpfull replies guys.Saved my night
Ask a new question

Read More

Graphics Cards Drivers AMD Graphics GPUs Resolution Monitors