Closed

Samsung Magician 4.3 doesn't recognize SSD 840 EVO 750 GB

Magician 4.21 worked perfectly, now with 4.3 it doesn't recognize the SSD.
I suspect because the SSD is plugged to the Marvel 9182 controller under Windows 8.1
Any idea?
Thanks
16 answers Last reply
More about samsung magician recognize ssd 840 evo 750
  1. It may well be the Marvell controller -- what model is your board?
  2. The MB is Asus Rampage III Black Edition. The strange is that 4.21 works perfectly.
  3. Bramax said:
    The MB is Asus Rampage III Black Edition. The strange is that 4.21 works perfectly.
    Did you upgrade to Magician 4.3 and then Update to Windows 8.1 or the other way around?

    To start I would uninstall Magician, download a new copy and reinstall it. If it still is a problem, then just download 4.21 from HERE just hit the red download link upper left corner and it will be 4.21.

    Off topic: And while this is not related to your issue, SATA III SSDs generally perform better on one of the native Intel SATA II controllers than on the Marvell SATA III -- the only thing you lose is a little sequential read and write, but you gain a lot in random read and write which is much more important for overall performance. I would estimate that about 99% of the members who work a lot with SSDs would agree with that idea.
  4. Thanks for suggestions.
    I did exatly what you wrote before reading your message and now I am using version 4.21. 4.3 refuses to recognize the SSD even if it installed on 8.1, uninstalling any previous version of Samsung Magician.
    The strange thing is that magician 4.3 shows the 840 EVO in the disks list and enumerates also its proprties.

    About off topic, I agree if you are speaking about Marvel 9128, that is very poor, although SATA III.
    My MB has 9182 that is using 2 PCIe lanes and has similar performances than Intel native SATA III controller.
    In my case going back to SATA II Intel controller would be a severe draw back.
  5. After further consultation, I will stick with my original suggestion to stick with an Intel SATA II port. :D
  6. RealBeast said:
    Okay -- 9182 you are good. I would drop an email to Samsung Support to put the issue on their radar, not that they will jump on it, but they will fix it eventually. :D


    We usually tell cx's to stick with the Intel port even if it is SATA 2. And when you tell us an issue like that, we have to send it to the guys in korea that make the program and they usually say for us to tell the cx to use the Intel port instead of the Marvell because of the known performance issues.
  7. I just called Samsung Support (1-800-SAMSUNG) about this issue. First, Magician 4.3 definitely supports Win 8.1, so no problem there. The tech said that the problem is the Marvell controller and that Magician does not work well with the Marvell drivers. He advised using the Intel ports.

    Are you able to enable Rapid Mode with ver. 4.21?

    Yogi
  8. Y0GI said:
    I just called Samsung Support (1-800-SAMSUNG) about this issue. First, Magician 4.3 definitely supports Win 8.1, so no problem there. The tech said that the problem is the Marvell controller and that Magician does not work well with the Marvell drivers. He advised using the Intel ports.

    Are you able to enable Rapid Mode with ver. 4.21?

    Yogi


    You spoke to me, lol, but yea, 4.2.1 was the version of magician that came out with the EVO, so yes it will do RAPID.
  9. Cool!

    Thanks, David!

    Yogi
  10. Bramax said:
    Magician 4.21 worked perfectly, now with 4.3 it doesn't recognize the SSD.
    I suspect because the SSD is plugged to the Marvel 9182 controller under Windows 8.1
    Any idea?
    Thanks


    I have exactly the same issue with my 840 Pro. Had to downgrade back to 4.21 - Marvell ports here too!
  11. I have the same problem with magician 4.3.
    My 840-EVO is not recognized.
    With version 4.2.1 everything is working fine.
    I do NOT have Marvel controller.
    I have Intel Raid controller.

    Helmi007
  12. helmi007 said:
    I have the same problem with magician 4.3.
    My 840-EVO is not recognized.
    With version 4.2.1 everything is working fine.
    I do NOT have Marvel controller.
    I have Intel Raid controller.

    Helmi007
    Is the controller actually in RAID mode? What motherboard model and which controller are you using?

    And in the future start a new thread as you have a different issue, the old threads tend not to get as much attention, particularly when it is a slightly different problem. Thanks.
  13. Yes, the controller is (and always was) in RAID-mode. (with single 840 EVO boot-SSD)
    My motherboard is ASUS P8H77-V LE
    and as I already wrote, I use the onboard Intel controller.
    Never had a problem in the past until Magician 4.3.

    Regards - helmi007
  14. I went around these problems a lot of times, trying different cables, boxes and bios configurations.

    In the end, I found that http://www.easeus.com/backup-software/tb-free.html fixed the problem - just ignore the Samsung software until it works again.

    I did a sector by sector copy (may not have been necessary, but I wanted to make sure it worked).

    For Windows 10, I found that in addition to this I had to make sure my BIOS was set to force AHCI mode - just making it optional didn't work.

    So far this has worked on Samsung Chronus and Sony Vaio laptops (mine and my wife's).

    ps - I have absolutely nothing to do with this company, I just got fed up with waiting for a version of Magician or Data Migration that worked all of the time (and the above software works free, although I suspect the paid version might be quicker)
  15. They are talking about Magician, not Mogration, also, i'm pretty sure you can't revive dead threads like this.
  16. Palorim12 said:
    They are talking about Magician, not Mogration, also, i'm pretty sure you can't revive dead threads like this.
    Agreed, I'll close this long dead thread. :)
Ask a new question

Read More

Homebuilt Evo Samsung Storage Controller Windows 8 SSD