Sign in with
Sign up | Sign in
Your question

Black Screen after installing nvidia gtx 560 (non ti) on Windows 7 with latest nvidia driver

Tags:
  • Gtx
  • Windows 7
  • Nvidia
  • Graphics
Last response: in Graphics & Displays
Share
December 13, 2013 2:08:35 PM

Hello, I'm tackling a problem since yesterday.

I installed my ZOTAC nvidia gtx 560 in my Win 7 computer with AMD Phenom X4 965 (QuadCore), 4 GB ram 1333 mhz, and Antec EA-500D; run the driver installation and run into a black screen or completely losing signal of te screen after I logged into Windows.

I really need help on this one, and thank you for your help in advance.

Note: I have also encountered a nvlddmkm.sys, but that was on installing the driver cd that comes with the card (before installing the latest nvidia driver).

More about : black screen installing nvidia gtx 560 windows latest nvidia driver

a b Î Nvidia
December 14, 2013 11:57:20 AM

what driver version you're using right now? did you use intel IGP or AMD gpu prior to installing your current 560?
m
0
l
January 9, 2014 11:47:01 PM

Log on in safemode if you can
The disable these:

Nvidia streamer service
Nvidia stereoscopic service
Nvidia network serviceservice

Worked for me anyway.
m
0
l
Related resources
April 23, 2014 2:33:27 PM

Garrett0051 said:
Hello, I'm tackling a problem since yesterday.

I installed my ZOTAC nvidia gtx 560 in my Win 7 computer with AMD Phenom X4 965 (QuadCore), 4 GB ram 1333 mhz, and Antec EA-500D; run the driver installation and run into a black screen or completely losing signal of te screen after I logged into Windows.

I really need help on this one, and thank you for your help in advance.

Note: I have also encountered a nvlddmkm.sys, but that was on installing the driver cd that comes with the card (before installing the latest nvidia driver).


m
0
l
May 10, 2014 9:40:11 AM

My solution:
Uninstall all NVDIA GTX 560 drivers. Boot into as issued resolution. W7 will automatically begin a search for drivers and will install those included in the W7 monthly update. After reinstall of new drivers the black screen issue went away.
m
0
l
!