Sign in with
Sign up | Sign in
Your question

Problem adding a sound card to asus z87 pro MB

Last response: in Motherboards
Share
December 14, 2013 8:49:39 AM

HI,
I just completed my first PC build. I have an asus Z87 pro MB with an asus HD7750 graphics card. It runs fine with just the graphics card but when I try to add a sound blaster audigy fx sound card the pc tries to boot to it instead of the HDD. I keep getting an A2 (IDE detect) error and the only way to get it to boot is to remove both the sound and display cards and go into bios and reset the boot order.
I've updated both the chipset and bios to the latest versions.

Also, what's up with the USB ports - my wireless mouse / keyboard are about useless.

thanks,
Lanna

More about : problem adding sound card asus z87 pro

a b V Motherboard
December 14, 2013 9:43:36 AM

Keep the sound card in and head to the BIOS. There change the boot order. If you are removing the card and resetting the order, it might be resetting to the sound card when you put it back in. About the USB, tell me more about what is happening. No power, no signal? Try using the USB on the case and see if those work.
m
0
l
December 14, 2013 9:59:35 AM

Hi,
I can't even boot to bios if the sound card is in. I've tried both the button on the MB and holding the delete key down when booting - sticks on the A2 error - sometimes AE but mostly A2.

Keyboard keeps "freezing" then typing very slowly. I've tried the ports on the mb and it doesn't work at all - only kinda works on the case ports - which are USB3.0.My keyboard/mouse are 2.0 but it's supposed to be backwards compatible.
m
0
l
Related resources
a b V Motherboard
December 14, 2013 12:18:40 PM

Is the CPU fan connected? If so. I would suggest clearing the CMOS. That might correct any messed up settings that could be messing up the computer. Also, try installing the sound card in different slots. Your USB might not be getting correct power. Check to make sure all connections to the motherboard are secure (24 Pin). Oh, and try to get into the BIOS and disable on-board sound. Also, did you install the drivers for it?
m
0
l
a b V Motherboard
December 14, 2013 12:46:05 PM

By the way, I am sorry how long it takes me to respond, and if I am actually being a help or not.
m
0
l
December 22, 2013 10:46:13 AM

Umzipumzi said:
By the way, I am sorry how long it takes me to respond, and if I am actually being a help or not.


HI,
No problem, I haven't tried troubleshooting for a while. Yesterday I put the sound card back in and it booted right up and worked great.. until the PC went into sleep mode, now I back with the same issue except now I can't even boot with the ASUS graphics card installed. If I pull the graphics card and the sound card and clear CMOS it boots. It's always worked with the graphics card so I'm at a loss as to why it suddenly won't - I get a A0 error. This is so frustrating. I've checked Bios and cleared CMOS numerous times and still am getting nowhere. I have a really nice HDMI monitor that I want to use so I need the graphics card. The sound card was an early xmas present.. might have to return it.

any help is greatly appreciated.

UPDATE: It now boots with the graphics card. All I did was boot into windows, use windows for a while, shutdown and reinstalled the graphics card and it booted right up. I'm confused.. :??: 
m
0
l
December 22, 2013 3:45:43 PM

Well, I think I've got it fixed. I didn't have the hdd on sata 1 so I moved it there, disabled the on-board sound in bios, and cleared CMOS. I reinstalled the sound card and it has booted with it installed a couple times so far. I'm keeping my fingers crossed...
m
0
l
!