Solved

Asus Z87 Gryphon Problem - First Build

Hello

Just yesterday I finished building my first PC. As far as I can tell I've plugged everything in right. However, when I plug it into a monitor, the monitor says to check the signal/cable and if I try using the HDMI cable on a TV, it will not read it. Furthermore, the DRAM_LED red light is on.

I've tried readjusting the ramsticks twice and have tried several monitors and TVs, but the problem still persists. How could I fix this?

My RAM sticks are 2 (two) G.SKILL Ripjaws X Series 8GB

Thanks in advance.
11 answers Last reply Best Answer
More about asus z87 gryphon problem build
  1. full system specs plz
  2. Sorry

    G.SKILL Ripjaws X Series 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1866 (PC3 14900) Desktop Memory Model F3-14900CL9D-8GBXL
    Mushkin Enhanced MKNSSDCR60GB-DX7 2.5" 60GB SATA III 7mm Internal Solid State Drive (SSD)
    NZXT Source 210 Elite Black Steel with painted interior ATX Mid Tower Computer Case w/ Black Front Trim
    CORSAIR Hydro Series H80i High Performance Water/Liquid CPU Cooler. 120mm
    Western Digital WD Blue WD10EZEX 1TB 7200 RPM 64MB Cache SATA 6.0Gb/s 3.5" Internal Hard Drive Bare Drive - OEM
    CORSAIR CX600M 600W ATX12V v2.3 SLI Ready CrossFire Ready 80 PLUS BRONZE Certified Modular Active PFC Power Supply
    ASUS GRYPHON Z87 LGA 1150 Intel Z87 HDMI SATA 6Gb/s USB 3.0 uATX Intel Motherboard
    Intel Core i5-4670K Haswell 3.4GHz LGA 1150 84W Quad-Core Desktop Processor Intel HD Graphics BX80646I54670K
    SAMSUNG DVD Burner SATA Model SH-224BB - OEM
  3. Warp Time said:
    Sorry

    G.SKILL Ripjaws X Series 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1866 (PC3 14900) Desktop Memory Model F3-14900CL9D-8GBXL
    Mushkin Enhanced MKNSSDCR60GB-DX7 2.5" 60GB SATA III 7mm Internal Solid State Drive (SSD)
    NZXT Source 210 Elite Black Steel with painted interior ATX Mid Tower Computer Case w/ Black Front Trim
    CORSAIR Hydro Series H80i High Performance Water/Liquid CPU Cooler. 120mm
    Western Digital WD Blue WD10EZEX 1TB 7200 RPM 64MB Cache SATA 6.0Gb/s 3.5" Internal Hard Drive Bare Drive - OEM
    CORSAIR CX600M 600W ATX12V v2.3 SLI Ready CrossFire Ready 80 PLUS BRONZE Certified Modular Active PFC Power Supply
    ASUS GRYPHON Z87 LGA 1150 Intel Z87 HDMI SATA 6Gb/s USB 3.0 uATX Intel Motherboard
    Intel Core i5-4670K Haswell 3.4GHz LGA 1150 84W Quad-Core Desktop Processor Intel HD Graphics BX80646I54670K
    SAMSUNG DVD Burner SATA Model SH-224BB - OEM


    Install the RAM sticks in Slot 1 and 3 or 2 and 4
  4. I have done that. The problem still persists
  5. u r using graphic card?

    your system fans r running?
  6. I am not using a GPU. It just wasn't in the budget right now so I planned to make due with the intel HD 4600 until I can buy one.

    The chassis fans do not run, but the installed h80i does.
  7. Best answer
    check everything.....and power supply is connected to motherboard preoperly

    check everything again ......
  8. It turns out it was a fan issue. I had to connect the fan to the heatsink. Manual didn't say anything about that...

    Nevertheless, thanks for your help.
  9. Warp Time said:
    It turns out it was a fan issue. I had to connect the fan to the heatsink. Manual didn't say anything about that...

    Nevertheless, thanks for your help.


    I have the issue you describe.....can you explain a bit more i n depth how you solved it?
  10. Jaleur said:
    Warp Time said:
    It turns out it was a fan issue. I had to connect the fan to the heatsink. Manual didn't say anything about that...

    Nevertheless, thanks for your help.


    I have the issue you describe.....can you explain a bit more i n depth how you solved it?


    There was a 3-prong cable protected by a cover on the cooler that had to be plugged into the heatsink itself (when I plugged it in, the corsair logo lit up, something that wasn't happening when I had the problem)
  11. I was have the same problem. The motherboard doesn't run until I connect HDD and DVD and after everytime that I change the HDD to make tests with others OS alwais I have problems to re-run again.
    Maybe my experience is useful for you.
    Thanks.
Ask a new question

Read More

Gryphon Motherboards Monitors